Announcement

Collapse
No announcement yet.

Sides not matching?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sides not matching?

    Strange behavior here:
    I'm comparing a local folder with an (identical) remote folder and the files and folder are not matched side by side (see the screenshot).
    The only strange thing is that the right folder is on a linux machine and the folder is "mounted" with mount --bind source destination (because is not directly accessible through ftp).
    However the BC Windows version works correctly.

    https://sites.google.com/site/screenshotbcmac/

  • #2
    Your mount point on the right side isn't parsing the FTP site directory listing correctly. If you look closely you'll see that the file's name is actually show as "9 web65_ftp web65 4096 Apr 18 18:06 wp-admin" rather than just "wp-admin". Based on your description of how things are set up it sounds like it's an issue with the "mount --bind" command.
    ZoŽ P Scooter Software

    Comment


    • #3
      Oops, I'm sorry, it's not a mount point, it should be a normal directory.
      I didn't notice however the wrong names!
      The strange thing is that BC window version is working correctly...
      If I manage to get access to the remote machine and have more information I'll post here.
      thx
      a,

      Comment


      • #4
        Thanks for the clarification. Would it be possible to get an FTP log with debug information enabled? To enable the debug info, go to the Beyond Compare menu -> Preferences dialog, select Commands, and go to the Tweaks command and enable it in the menu.

        Then go back to the Beyond Compare menu -> Tweaks, and in the Folder Views tab, enable "Include debug messages in log". You can then post or email your log to support@scootersoftware.com

        If you email us, please include a link to this forum thread (http://www.scootersoftware.com/vbull...ad.php?t=11798) as reference.
        Aaron P Scooter Software

        Comment


        • #5
          I sent the logs. Only thing I can add is that the same is happening on other servers from another provider...
          Again the only difference I see in the logs is:
          on Mac
          5/6/13 5:18:24 PM Sent> TYPE A
          5/6/13 5:18:24 PM Recv> 200 TYPE is now ASCII

          on Win:
          06/05/2013 17:20:40 Sent> TYPE I
          06/05/2013 17:20:40 Recv> 200 TYPE is now 8-bit binary

          a.

          Comment


          • #6
            Thanks. Received your email. This is likely a bug in the current alpha release.

            If you disable the MLSD option in the Beyond Compare -> FTP Profiles, <default> profile, Listing tab, does this help?

            If the options do not show, drag and re-size the window to force a re-draw.
            Aaron P Scooter Software

            Comment

            Working...
            X