Announcement

Collapse
No announcement yet.

Error with High Sierra

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • DaveAugustus
    replied
    ok - the reboot cleared the problem and BC now runs - thanks!

    Leave a comment:


  • DaveAugustus
    replied
    Nothing in my User directory - only /Applications....

    /Applications/Beyond Compare.app/Contents]$ cat Info.plist |grep 4.2 -A 5 -B 5
    <key>CFBundleName</key>
    <string>Beyond Compare</string>
    <key>CFBundlePackageType</key>
    <string>APPL</string>
    <key>CFBundleShortVersionString</key>
    <string>4.2.4.22795</string>
    <key>CFBundleSignature</key>
    <string>BCmp</string>
    <key>CFBundleVersion</key>
    --
    <key>CFBundleSignature</key>
    <string>BCmp</string>
    <key>CFBundleVersion</key>
    <string>4020.42.79</string>
    <key>CSResourcesFileMapped</key>
    <true/>
    <key>LSEnvironment</key>
    <dict>
    <key>LC_CTYPE</key>


    Originally posted by Aaron View Post
    Hello,

    If you navigate to /Applications/ and /User/username/Applications/, which location has Beyond Compare.app, and can you double check the Version?

    BC 4.2.4 should work; have you rebooted your Mac as well to make sure it isn't in a bad state?

    Leave a comment:


  • Aaron
    replied
    Hello,

    If you navigate to /Applications/ and /User/username/Applications/, which location has Beyond Compare.app, and can you double check the Version?

    BC 4.2.4 should work; have you rebooted your Mac as well to make sure it isn't in a bad state?

    Leave a comment:


  • DaveAugustus
    replied
    Problem still exists when trying to run from CLI - here is my console output:

    /Applications/Beyond Compare.app/Contents/MacOS]$ ./BCompare
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'

    I just downloaded and installed the latest release, 4.2.4 , BCompareOSX-4.2.4.22795.zip, and it still does not load. Running it from the command line, like I showed above, results in that error. Running from any other way results in me having to "Force Quit" the application.

    Thanks,
    Dave

    Leave a comment:


  • Chris
    replied
    Version 4.2.4 is now available, it fixes the error messages when using BC from the command line on macOS 10.13 High Sierra.

    Leave a comment:


  • Chris
    replied
    The bug will be fixed in Beyond Compare 4.2.4. It's currently in internal testing; the release has been delayed a bit due to staff being out for holiday vacations and winter cold and flu season.

    Leave a comment:


  • dmoore210
    replied
    +Bump.
    It's been three months - any ETA on this? The primary reason I use BeyondCompare is with git. But I get this error on every file and makes it a bit difficult to sift through the errors to see what's going on.

    Leave a comment:


  • Chris
    replied
    Thanks for sharing the workaround. You might be able to follow the Older versions of Git instructions on our Mac version control page, then redirect output in the call to bcomp or wrap the call to bcomp in a script that redirects output.

    Leave a comment:


  • Narbat
    replied
    Originally posted by eppsilon View Post
    This issue is pretty annoying if you're using Git on the CLI with BC as the difftool. You get 6 lines of errors for every file that has changed. Is there a workaround to suppress the messages?
    You can redirect error messages to the bit bucket by appending "2> /dev/null" to the command line. (Using bash, anyway. Other shells probably have other ways to redirect stderr.)

    Code:
    macabre:~$ bcompare a b 2> /dev/null
    macabre:~$ git difftool 2> /dev/null
    It's kind of a blunt instrument; using the redirection with git will discard *all* errors from git, which is less than ideal. It's probably possible to configure git to call bcomp or bcompare with the redirection so only BC4 error messages are discarded, but I'm not familiar enough with git to know how.
    Last edited by Narbat; 15-Nov-2017, 02:51 PM.

    Leave a comment:


  • Chris
    replied
    Sorry, there isn't a workaround that we're aware of. The error should be fixed in the next release of BC, but it doesn't have a set release date.

    Leave a comment:


  • eppsilon
    replied
    This issue is pretty annoying if you're using Git on the CLI with BC as the difftool. You get 6 lines of errors for every file that has changed. Is there a workaround to suppress the messages?

    Leave a comment:


  • Aaron
    replied
    Hello,

    It's still an open issue that we're investigating. Is it possible for your script to workaround the current bug by ignoring lines with "compress" mentioned as part of the error? The error text usually contains "unsupported compressor" or " unknown compression scheme"

    Leave a comment:


  • Sumonto
    replied
    Hi
    Any update on the fix?
    This error breaks my scripts

    Thanks

    Leave a comment:


  • Chris
    replied
    Thank you, I've duplicated the error on macOS High Sierra 10.13. I'll add it to our bug list.

    Beyond Compare 4.2.3 still appears to launch and run a comparison correctly despite displaying the errors to the terminal.
    Last edited by Chris; 27-Sep-2017, 11:58 AM.

    Leave a comment:


  • kf0s
    started a topic Error with High Sierra

    Error with High Sierra

    Seeing the following error starting BCOMP:

    $ bcomp
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'
Working...
X