Announcement

Collapse
No announcement yet.

macOS High Sierra 10.13 Beta problems

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by Aaron View Post
    Thanks for the workaround. It isn't needed in the most recent release (4.2.3) since we've incorporated a fix in that release, but if other users are running into this issue with the MacOS beta and other applications, this could be useful.
    I'm running 4.2.3 and upgraded from Sierra to High Sierra yesterday and am getting a whole lot of this (something mentioned earlier in this thread) when I use `bcomp` (as is used in `git difftool`):

    Code:
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
    /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'

    Comment


    • #17
      Thank you, I've duplicated the error on macOS High Sierra 10.13. I'll add it to our bug list.

      Beyond Compare still appears to launch and run a comparison correctly despite displaying the errors to the terminal.
      Chris K Scooter Software

      Comment


      • #18
        I'm seeing a similar issue on macOS 10.13 public release.
        Beyond Compare v4.2.3 (build 22587)

        The program is working, but seeing the following errors when launching from command-line:
        Code:
        /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
        /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'
        /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
        /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'
        This thread is the first result on google for
        macOS 10.13 "unsupported compressor"|"Unknown compression scheme encountered for file"

        Comment


        • #19
          Same errors here! BC 4.2.3 (22587) + High Sierra 10.13 (17A365)
          Any chance for a fix soon?

          Comment


          • #20
            luckman212,

            It's on our bug list, but doesn't have a scheduled fix date.

            Is the bug preventing you from using Beyond Compare on macOS 10.13, or just displaying messages to the terminal window? When I tested on macOS 10.13, Beyond Compare still appeared to operate correctly despite the error messages displayed.
            Chris K Scooter Software

            Comment


            • #21
              Ok thanks. Yes I can still use BC - it's just a bit of clutter on ther console is all.

              Comment


              • #22
                I'd just like to throw in that I'm seeing this constantly and it's driving me nuts

                Code:
                /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
                /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'
                /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
                /BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.1.1/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'

                Comment


                • #23
                  Thanks, it's still on our bug list for an upcoming version.
                  Chris K Scooter Software

                  Comment


                  • #24
                    Originally posted by Chris View Post
                    Thanks, it's still on our bug list for an upcoming version.
                    Any progress? Still having this.

                    Comment


                    • #25
                      Yes, we are working on a fix for this in the next release. We don't have an announced release date, but we're currently working on testing.
                      Aaron P Scooter Software

                      Comment


                      • #26
                        Version 4.2.4 is now available, it fixes the error messages when using BC from the command line on macOS 10.13 High Sierra.
                        Chris K Scooter Software

                        Comment


                        • #27
                          May I ask what the side effects were for this error? I can run diffs locally from my context menu but it seems my attempts at the command line all fall short on macOS High Sierra 10.13.4. I too get the above BuildRoot console messages with a different AppleFSCompression version number. The Beyond Compare GUI launches, but it never displays the folders I indicated in my arguments, it launches as if I just double clicked the Beyond Compare.app icon in Applications, just to the main home page.

                          Is there any workaround for using bcomp instead of bcompare? Issuing bcomp commands seems to get my arguments recognized but I can't figure out the syntax and always bring up some kind of 3 way merge view.

                          Comment


                          • #28
                            Hello,

                            This was just the message text, with no other side effects for 10.13.3. We have not finished testing the latest 10.13.4beta.
                            Aaron P Scooter Software

                            Comment


                            • #29
                              To troubleshoot the Merge launching, can you include the code/text you are using to execute the comparison from the command line?
                              Aaron P Scooter Software

                              Comment

                              Working...
                              X