Announcement

Collapse
No announcement yet.

GIT 2.10 VCS with BC4 4.19 on Mac can't get it to work

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GIT 2.10 VCS with BC4 4.19 on Mac can't get it to work

    Hi all I have scoured these forums and the internet and I can't get beyond compare to work with git

    git difftool file.ext

    does nothing no matter what I try or do

    latest is

    these steps

    git config --global diff.tool bc3
    git config --global difftool.bc3.trustExitCode true
    git config --global merge.tool bc3
    git config --global mergetool.bc3.trustExitCode true
    ln -s /usr/local/bin/bcomp /usr/local/bin/bc3

    which give the following ~/.gitconfg

    [diff]
    tool = bc3
    [difftool "bc3"]
    trustExitCode = true
    [merge]
    tool = bc3
    [mergetool "bc3"]
    trustExitCode = true

    If anybody gots something that actually works please share

    Troy

  • #2
    Hello,

    Delete your ln that created a "bc3" link. bc3 is a keyword that Git has internally defined, and should not directly match an existing entity on your system (it's Git's method of calling to bcompare, and they haven't updated the keyword to "bc" or "bc4" yet, but still works).

    If you haven't installed bcompare/bcomp, then you'll want to launch Beyond Compare, and use the Beyond Compare menu -> Install Command Line Utilities to create these shortcuts (bcompare and bcomp).

    You can then test them on your Terminal command line. Can they launch the application? If you pass in two test files does it launch?

    A full set of instructions is found here:
    http://www.scootersoftware.com/suppo...kb_vcs_osx#git
    Aaron P Scooter Software

    Comment

    Working...
    X