Announcement

Collapse
No announcement yet.

Confused about how to set up profile with ssh key

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Confused about how to set up profile with ssh key

    I'm trying to connect to a site where I have a ssh key BUT NO PASSWORD. I've set up the keys correctly so I can "ssh THAT-SITE" successfully from the command line.

    I have gone to the profile dialog, created a new profile, and put the private key file in the box indicated.

    I left the password blank.

    When I try to connect it asks me for a password, which I don't have because there is no password access to this server.

    How do I connect to this server? I've put in the same info that is contained in my ~/.shh/config file: the hostname, user, port, and identityfile.

  • #2
    Hello,

    Do you have the Remember Password box checked? If you used a previous beta build, this might be checked and shouldn't be if you have a Private Key defined.
    Aaron P Scooter Software

    Comment


    • #3
      Do you mean the "Save Password?" checkbox on the "Login" tab just above the "SSH Private Key File" prompt?

      I tried that both ways and it doesn't change anything.

      Comment


      • #4
        Can you email us at support@scootersoftware.com with a link back to this forum post and a copy of your log? Your private key may be failing (at which point, we do fall back to prompting for a password).

        For troubleshooting purposes, it may help to disable the Save Password checkbox, then restart BC4, just to be certain the settings are applied and not cached in some way. Toggling the option won't help if you want to use the key; it must be disabled.

        Update: To fully restart, right click the taskbar icon and select to Quit to fully shut down.
        Aaron P Scooter Software

        Comment


        • #5
          I tried a different server and it worked. This particular server is in a university and there are lots of security measures. I can ssh into it using a key, so I assumed that's what BC is doing, too. I guess BC is doing some other command that perhaps the server has disallowed?

          Comment


          • #6
            And, by "Log", you mean the log that appears in the view or is there a more complete log somewhere that would be helpful? the view just says:

            Connecting to xxx
            Server key [ssh-rsa xxxx]
            Connection failed: Operation cancelled
            Unable to load xxxx: Operation cancelled.

            Comment


            • #7
              SSH (using a command line) and SFTP are different but related protocols. It is possible that SHH is enabled, but that SFTP was disabled.

              They are commonly configured together, but as you mention, it would depend on the security.
              Aaron P Scooter Software

              Comment


              • #8
                Sigh, back to IT.

                Thanks for the great support and the great product! And especially the OSX version so I don't need Parallels.

                Comment


                • #9
                  Another test is to try another client like Filezilla (just in case it is a bug with BC4), and see if you can connect using SFTP.
                  Aaron P Scooter Software

                  Comment


                  • #10
                    I do fully agree that the current SSH/SFTP user experience is quite low.

                    As a user, I do expect not to be able to connect to a server via SSH/SFTP without having to configure anything: username, password or private key, just as ssh command line works.

                    ssh from command line will use current username by default and will also use private keys from .ssh directory or loaded by the system agent.

                    Now this doens't work in BC4 and and even if you may try to configure them you end up with cryptic error messages. (like the 103 one)

                    https://www.dropbox.com/s/ea9z1gq2ky...2014.43.32.png

                    Also, unrelated, as a user of a beta version of the product, I do expect to have a new build with bug fixes or even new features as least once a month. If Apple can do this with an entire operating system, I am sure a smaller company can do much better (automation is the key!).

                    Comment


                    • #11
                      Hello,

                      The current build of the BC4 beta does use the current OS user as the SFTP username if a user is undefined, and does use the current .ssh/ private key if no password is defined and Save Password is disabled in the Profile. If you are still having trouble, are you able to use the current Private key file if it is explicitly defined with a saved Profile with a defined username? We've seen some issues with specific public/private key pairs, so this might be an issue with BC4 using the specific key file. We'll need a full copy of the log to help troubleshoot; you can email it to support@scootersoftware.com, along with a link back to this forum thread.

                      Of note, the username can be case sensitive, which can cause the authentication to fail if the sftp and host OS have differing upper and lowercase characters in the username.

                      We are a substantially smaller company than Apple, with under a dozen total employees. Our developers are working on both BC3 and the BC4 beta simultaneously, with new builds every couple of months. Not all of the changes are immediately apparent, but many are substantive, such as the complete overhaul of the 'guts' of the Picture Compare in the latest beta build. Plus, fixes for the Samba support that OSX 10.9 broke. Our release schedule trends and development are documented in our changelogs:
                      http://www.scootersoftware.com/ChangeLog.txt
                      http://www.scootersoftware.com/beta.php?zz=beta4_log
                      Aaron P Scooter Software

                      Comment

                      Working...
                      X