Announcement

Collapse
No announcement yet.

bc4's feedback

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • bc4's feedback

    1. It does not support import version 3 binding, setting..., it boring

    2. git integration seem like not worked, I use same as bc3 config, It seem always content is empty when bcompare started.

    3. Where to setting hokey?

  • #2
    1. We do support importing your BC3 settings. Which settings specifically cannot import? Can you email us at support@scootersoftware.com with a copy of your BC3Settings.bcpkg that you are trying to import? Please also include a link to this forum post.

    2. What settings did you use exactly? Did you call the shortcut "bc3"? Git was updated to support BC3 directly when the "bc3" shortcut text is used. This may also work for BC4, or you may need to use the "Older" method with "bc4" until Git updates to support BC4.

    3. Hotkeys are configured under Tools -> Options dialog -> Toolbars, etc: Select View (Home, Text Compare, etc).
    Aaron P Scooter Software

    Comment


    • #3
      1. Sorry, The same platform version is supported.

      2. it my fault, I use bcompare as git intergation command nor bcomp, bcomp is worked.

      3. Thanks.

      Comment


      • #4
        Hi, Aaron, I found Mac version bc4, When open Toolbars, etc. => Shortcut, have some binding display for `???G' `^??????', and I can not binding any key to meta(options) key too , All Options + ? can not be detected. (I have removed default Options keyboard layout, So, I can binding any Meta + ? in others applications)

        Comment


        • #5
          Hi, I just ensure about, ??? is Apple options key, it can not display in bc3 keybinding setting correctly. It can not be setting correctly too.

          Comment


          • #6
            Thanks for the report. Which language and version of OSX are you currently running?
            Aaron P Scooter Software

            Comment


            • #7
              OS X 10.9.2,

              I have setting below environment variable:

              export LANG=en_US.utf8
              export LC_CTYPE=UTF-8

              Comment


              • #8
                Another feedback:

                in the top menu bar, between `Beyond Compare' and `Session', the About menu display a `?'.

                Comment


                • #9
                  btw:

                  I hope BC3 can support setting `Options + CHAR'(Alt + Char) keybinding setting.

                  anyway, the guys like me (come from Linux), maybe change keyboard layout, make all
                  `meta + CHAR' available for get same feeling with Linux.

                  Comment


                  • #10
                    Hi, It seem like my fault too..

                    When I setting
                    `export LANG=en_US.utf8', cause following problem

                    1. Can not display Chinese char correct. (with ???)
                    2. Keybinding display not correctly.
                    3. menu bar, BeyondCompare menu split to two part. it Showing like Following:
                    BeyondCompare ? Session File ...

                    When I remove `export LANG=en_US.utf8', it display normally.

                    Anyway, Other software, I'm not found display problem like this, perhaps can improve?

                    Comment


                    • #11
                      It's seem like command + options binding can not used too.

                      in Mac, more binding constitute with command, I think bc3 should support
                      option + ?
                      command + option + ?

                      I use one IDE named RubyMine (same as IntelliJ IDEA in java), It can binding any
                      combining if I fix keyboard layout to make option available.

                      Comment


                      • #12
                        Are you able to set the Command + Option binding if you remove export LANG=en_US.utf8? We're still working on getting a test system setup, but I've documented your feedback.
                        Aaron P Scooter Software

                        Comment


                        • #13
                          I have remove all LANG setting now on mac, still not setting this.

                          Comment


                          • #14
                            It seem like sometimes, Command + Options + somekey Can work ....
                            But at about mostly times, It can not be used, But Command + ?, always work.

                            So , I think something is wrong ?

                            Comment


                            • #15
                              Are the specific combinations repeatable, or is it really randomly allowing the same combination sometimes, but then not other times?
                              Aaron P Scooter Software

                              Comment

                              Working...
                              X