Announcement

Collapse
No announcement yet.

bc4's feedback

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Any Command + Options binding, I don't know what happen, it can be active in binding setting rarely times, the mostly time, it can not used, But, I used another software, RubyMine, the same time, always can used any binding, perhaps it not global binding things.

    Another problem, How Can I add a Ruby grammer config?
    If BC3 plan to support Ruby, I can offer a grammer config XML files (bc3 version)

    Comment


    • #17
      BC3 could have a custom File Format defined for Ruby syntax. BC4 can also import BC3 formats. Have you tried importing using the Tools menu -> Import dialog?
      Aaron P Scooter Software

      Comment


      • #18
        I ever do it, but it not worked, because Mac version XML seem like not support linux bc3 XML,

        it's one of my current post problem...

        I have not tried to only import format definition, instead, I import all things, it failed.

        Comment


        • #19
          Another feedback:

          if not setting LANG=en_US.utf8 in mac, beyond compare will not support directory name with
          unicode char,

          example: bcompare $'/tmp/�\2105337584�\211/' $'/tmp/�\21009a162f�\211/', will cause following error:

          38373 Trace/BPT trap: 5 bcompare "$@

          But in this case, bcompare show character correctly, e.g. `Options' picture, Command picture,
          Menu, and Chinese content.

          if setting LANG=en_US.utf8, shell directory will work correct.
          for example:
          bcompare $'/tmp/zenburn-emacs\357\274\2105337584\357\274\211/' $'/tmp/zenburn-emacs\357\274\21009a162f\357\274\211/

          but in this case, Options, Command picture and Menu will show as ??, And, bcompare can not
          correct show Chinese too.

          So, What should I to use with : )

          Comment


          • #20
            I have import Ruby format, But, it seem like all keyword is not showed as special color. only string is colorful, Why?

            Comment


            • #21
              What is your LANG when it isn't en_US.utf8? I thought we checked this earlier and you were using en_US.utf8? Have you switched to another?
              Aaron P Scooter Software

              Comment


              • #22
                Hello,

                The color a grammar uses is controlled in the Options dialog, Colors,Fonts, File Views tabs, and scroll down and select the grammar name, then give it a color.
                Aaron P Scooter Software

                Comment

                Working...
                X