No announcement yet.

Merging from P4V doesn't work

  • Filter
  • Time
  • Show
Clear All
new posts

  • Merging from P4V doesn't work

    In the last couple of updates, merging hasn't worked for me when using P4V.

    I have the location set to: /Applications/Beyond Compare and the arguments set to: %1 %2 %b %r

    When I try to resolve/merge a file, it opens up BC, but goes to the regular opening screen like it would if you opened up the app normally. I've tried using bcomp and bcompare, but it either shuts down immediately or has the same behavior I described.

  • #2

    You'll need to use the command "Install Command Line Tools" to generate bcomp and bcompare, then use those for your version control needs. We have more details here:
    Aaron P Scooter Software


    • #3
      I've done that already (and had in the past as well). It doesn't seem to be creating an actual merge session for me. It will open BC, but just goes to the Home screen instead of showing the merge session it should create.


      • #4
        Could you provide specific details on the command line and parameters provided? For example, I would expect the path to be /usr/local/bin/bcomp

        Does adding quotes around each variable help?:"%1" "%2" "%b" "%r".

        If you use the terminal and pass a similar command line (using 4 temp files) does bcomp launch and work as you expect? bcomp "file1" "file2" "center" "output"
        Aaron P Scooter Software


        • #5
          Well, that seems to work. Previously I was trying to use the bcomp in the actual app itself. Why is there a difference between the two? It seems like I should be able to point it at the app and have the app figure that out itself rather than having to install the command line programs and then point it at that.

          Either way, at least it works now.