No announcement yet.

Crash on OSX 10.9.1

  • Filter
  • Time
  • Show
Clear All
new posts

  • Crash on OSX 10.9.1

    I have updated two machines to OSX 10.9.1. On one machine BC runs as smooth as ever. On the other, I can no longer launch BC4. I get this error message:

    BcVersion: 4.0 beta (pro build 17036)
    BcExe: /Users/claussternberg/Downloads/Beyond
    BcSettings: /Users/claussternberg/Library/Application Support/Beyond Compare

    19/12/13 01.16.01
    UUID: 491F1382-8F76-335D-A99A-7E8F40B3FD95
    Beyond Compare Version 4.0 beta (build 17036)
    Exception occurred at: 958CED5A
    EAccessViolation: Access violation.
    $001A29D5 EXISTINGINSTANCEFOUNDCALLBACK, line 814 of BcStartup
    $000D967F ISAPPALREADYRUNNING, line 504 of SsSingleInst
    $001A3CD7 BCISALREADYRUNNING, line 1269 of BcStartup
    $001A187D CARBONOPENAPPHANDLER, line 515 of BcStartup

    SysName: Darwin
    NodeName: clauss-mac
    Release: 13.0.0
    Version: Darwin Kernel Version 13.0.0: Thu Sep 19 22:22:27 PDT 2013; root:xnu-2422.1.72~6/RELEASE_X86_64
    Machine: x86_64

    I have tried to reinstall but it did not help.

    Any suggestions?

  • #2
    Just tried again. It turns out that the program actually is running, but the opening screen is just not shown. The top menu is there and I can select e.g. a new FC session and everything is fine. If I close the open window(s) and click the dock icon (which is indicating the app as running) the error message is shown again.

    PS: The screen shot was when I ran the program directly from the download folder. It is the same when I move the app to the applications folder and run it from there, and via the dock.


    • #3
      Thanks. If you shut down BC4 entirely and then update to the latest release, do you then run into trouble? We have some single instance fixes in the latest release.
      Aaron P Scooter Software


      • #4

        I have just tried BC4 for Mac for the first time and it refuse to start or show the startscreen.
        I have installed BCompareOSX- on OSX 10.9.1


        • #5
          Does it give any output at all, or does it just bounce on the dock and then stop?

          If you're familiar with the Terminal app, you can fun BC from the command line using the path /Applications/Beyond\ If you run it that way it may output more logging to the terminal window that should help us debug the issue.
          ZoŽ P Scooter Software


          • #6
            Originally posted by Aaron View Post
            Thanks. If you shut down BC4 entirely and then update to the latest release, do you then run into trouble? We have some single instance fixes in the latest release.
            I can confirm that a total kill of the app and restart (no reinstall at first) seems to remove this error.

            Merry Xmas and Happy New Year (and congrats for moving into public beta)



            • #7
              I saw the same behavior again after upgrading to 17440. Again a kill and restart removed the problem.


              • #8
                Are you getting the updates using the Check for Updates support, or by downloading and extracting the zip yourself? Is it a state that the app gets into after some time, or something you can get it to do reliably?
                ZoŽ P Scooter Software


                • #9
                  this time I downloaded the update "manually" and dragged it to the application folder.
                  I am not sure what triggers it so I can not actively reproduce it. I will notice what were going on before if I encounter it again.

                  I believe I actually did start the program once after dl without problems, so it had been running but shut down via the program menu.

                  As said, I will keep an eye on it and report if it happens again.