Announcement

Collapse
No announcement yet.

After Upgrade, copy folder just hangs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • After Upgrade, copy folder just hangs

    This happened after I upgraded to BC 4.3.1 (now running on Xubuntu 19.10)

    What's happening:

    I do a compare on 2 folder structures.
    Editing files works great.
    Copy single files over works great
    I can manually create folders using the right-click "new folder" action in the main view.

    Copy over a folder (no matter how full or empty) shows a status bar at the bottom (above the logs) but then it just hangs there, if I try and use the pause or cancel button, nothing happens. I can still interact with the interface, but if I try and copy more things it just adds to another status-bar (even single files at this point). From here nothing happens and the only way I can get out of the application is to kill it. After kill, I can confirm that the copy has not happened, nothing was created.

    My current work around is that if I need to copy a folder, is to first create all the folders/subfolders manually, then copy the files 1 folder at a time (multi-file copy works, as long as it doesn't need to traverse a folder). Depending on the structure, this can be a bit tedious, or I just do it in the file manager and then reload.

    Included are my settings export, though they are mostly out of the box settings and this is something that just popped up. I've tried this on a number of different folders, so it's not isolated to 1 particular set. I've tried reinstalling, same issue. Guessing that whatever this issue, I may need to rollback a version in order to get this working again.

    Any help appreciated. Thanks!
    Attached Files
    Last edited by Tecktron; 28-Oct-2019, 11:54 PM.

  • #2
    I second this. I've exactly the same behaviour on my machine. (BC 4.3.1 Ubuntu 18.04.3 LTS)

    Comment


    • #3
      I'm seeing this too, after installing 4.3.1 (build 24438). I'm running Linux Mint 19.

      Comment


      • #4
        Thank you, we're investigating the Linux Folder Compare Copy hang in version 4.3.1. If you're affected and you'd like to roll back to version 4.3 until we release a fix, please email support@scootersoftware.com for a link to the old version.
        Chris K Scooter Software

        Comment


        • #5
          I've now duplicated the issue. It appears to specifically happen when the Copy confirmation dialog is disabled. To avoid the bug until we release a fix:

          Open Tools > Options.
          Go to the File Operations section.
          Check Confirm file copy and click OK.
          Chris K Scooter Software

          Comment


          • #6
            Thanks Chris, turning the confirmation dialog back on did get the copy working.
            Hopefully you get this bug cleared up in the next release.

            Cheers!

            Comment


            • #7
              To circle back on this, it also seems that if I'm copying a folder over an existing folder and it has to ask if I want to replace a file, selecting yes or yes to all also makes it hang. Again, doing a copy one by one or limiting it to just a few files with the same folder at a time, it works.

              Hopefully you get this solved soon.

              Comment


              • #8
                Should be soon. We are currently in QA for a 4.3.2 candidate we hope to have out soon.
                Aaron P Scooter Software

                Comment


                • #9
                  Beyond Compare 4.3.2 is now available on the download page, it should fix the Folder Compare copy hang on Linux.
                  Chris K Scooter Software

                  Comment


                  • #10
                    Yes that fixed it!
                    Awesome!
                    Thank you.

                    Comment

                    Working...
                    X