Announcement

Collapse
No announcement yet.

Context menu / Shell integration with Linux Mint Cinnamon 19.2

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Context menu / Shell integration with Linux Mint Cinnamon 19.2

    I have used versions of BC with older versions of Linux Cinnamon (18.x), and BC always appeared in the context menu.
    Not so for Cinnamon 19.2. I don't know what could have changed. I did check the Tools->options [x] Include Beyond Compare
    settings. In fact, I tried enabled all 5 methods in both 'main menu' and 'submenu'. Rebooted after, of course.

    I noticed the instructions for manual methods: Copying an .so file from
    /usr/lib/beyondcompare/ext/bcompare-ext-nemo.i386.so
    to...
    /usr/lib/x86_64-linux-gnu/nemo/extensions-3.0/bcompare-ext-nemo.so
    NOTE: I removed .i386 from the file name, as per instructions.
    Rebooted again.
    No change.

    I noticed that there was already a version of bcompare-ext-nautilus.so in
    folder /usr/lib/x86_64-linux-gnu/nautilus/extensions-3.0/. The size matches
    the relative file bcompare-ext-nautilus.amd64.so in the BC/ext folder. Note
    that this is the amd64 version, not i386. But given that was already copied
    to the nautilus/extensions-3.0 folder, it obviously did not work.

    Any ideas?


  • #2
    Thought I'd follow up, since I may have this working now. I copied the -amd64- version of the -Nemo- file to the nemo folder. The 'amd' part of the file name is misleading. I had tried the i386 version first, since the processor is Intel. But apparently that's the 32-bit version.

    Also, BC appears to be installing to the nautilus folder, rather than nemo.

    I also had trouble with the context menu not showing up for networked drives, but that is a different subject.

    Comment


    • #3
      Linux Mint 19.2 Cinnamon requires manual context menu installation, followed by logoff/logon:

      Manual context menu installation (64-bit):
      Code:
      sudo cp /usr/lib/beyondcompare/ext/bcompare-ext-nemo.amd64.so /usr/lib/x86_64-linux-gnu/nemo/extensions-3.0/bcompare-ext-nemo.amd64.so
      Fixing the context menu install for Linux Mint 19 Cinnamon and enabling the context menu for network drives are both on our bug list.
      Chris K Scooter Software

      Comment


      • #4
        Glad to hear that those two items are on the list.

        I also noticed that when a folder with underscores (_FOLDER_NAME) is selected via the context menu, it shows up without the underscores (FOLDERNAME).

        Comment


        • #5
          I tested folders starting with underscore, but they opened correctly when I tested on Linux Mint 19.2 Cinnamon 64-bit with BC 4.2.10.

          For the test, I did a right click in Nemo and selected Create New Folder to make folders named _test1 and _test2. I selected both folders, then right clicked and selected Compare. The files opened in Beyond Compare with the correct underscore name.

          Please describe the steps that fail to load the underscore folder names from the context menu in more detail.
          Chris K Scooter Software

          Comment


          • #6
            Hi Chris,

            See if this works for you: R-click on folder "1_2" and select "Select Left Folder." Then right-click again. The menu that I see says "Compare to '12' (no underscore).

            Comment


            • #7
              Thanks for the additional information, I duplicated the issue, I'll add it to the bug list for a future version of Beyond Compare.
              Chris K Scooter Software

              Comment


              • #8
                Very good, Chris. I could have reported the underscore glitch more clearly. II'd love to have the r-click context menu for networked drives under Linux. I haven't figured out any elegant ways around that, short of navigating to the networked folder and capturing the folder name. Or typing a lot.

                Comment


                • #9
                  Hello,

                  If you have the network drive loaded in a File Explorer, can you drag and drop a folder from it onto the main BC4 interface? BC4 also supports the Go To Server syntax into the folder or file path, smb://server/folder/item
                  Does this help?
                  Aaron P Scooter Software

                  Comment

                  Working...
                  X