Announcement

Collapse
No announcement yet.

Vague external program error

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vague external program error

    Hello,

    I'm using Beyond Compare 4 Pro (4.2.10 build 23938) on Ubuntu 18.04 LTS installed via Snap/ Ubuntu Store.

    My goal is to compare two java jar files and compare the decompiled .class files within. It has worked in the past but for some reason has stopped working.

    Here is my external config for jad
    Click image for larger version

Name:	2019-07-22T15:24:17.png
Views:	151
Size:	115.7 KB
ID:	81138


    If I copy a class file out of the jar and run the jad command it works fine
    # /usr/local/bin/jad -p '/.../MyClass.class' 2>&1 | head
    The class file version is 52.0 (only 45.3, 46.0 and 47.0 are supported)
    .......
    # echo $?
    0
    It has all the permissions
    # ls -lah /usr/local/bin/jad
    -rwxrwxrwx 1 danfredell danfredell 940K Aug 5 2001 /usr/local/bin/jad
    Looking in ~/log/BcLogTrace.txt the only thing is:
    External program "/usr/local/bin/jad" not found
    So I wish that Beyond Compare could give me a better error message as to why my class to java conversion via jad isn't working. I saw in https://www.scootersoftware.com/vbul...gram-not-found Aaron says
    If the conversion fails for any reason and we are getting an ErrorCode back or an empty file, our error text is incorrect and blames the lack of the External Program.
    If that is what I'm hitting, can you enhance Beyond Compare to print a more helpful message?

  • #2
    This is a limitation of the community provided Snap package of Beyond Compare. Snap packages are isolated from the system, this prevents Beyond Compare from running jad. Beyond Compare displays the 'not found' message because of snap isolation. To resolve the issue, uninstall the snap version of Beyond Compare and install the deb package from our website.

    To uninstall the snap package:
    sudo snap remove bcompare

    Then download and install the .deb package of Beyond Compare from the downloads page.

    Known issues when running Beyond Compare as a snap package are listed in the following article:
    https://www.scootersoftware.com/supp...z=kb_linuxsnap
    Chris K Scooter Software

    Comment


    • #3
      Thanks Chris,

      I uninstalled the Snap version of Beyond Compare and installed the deb from your downloads page. I did loose all of my configuration and product key when I uninstalled the snap version. I have added the jed converter back and now it works.

      Comment


      • #4
        I'm glad that resolved the issue. I asked the author of the Beyond Compare snap package to pull it from the repository because of all the issues with that package format.
        Chris K Scooter Software

        Comment

        Working...
        X