Announcement

Collapse
No announcement yet.

Problem launching bcompare Ubuntu 18.10

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem launching bcompare Ubuntu 18.10

    I installed the latest version of BeyondCompare 4.2.8-23479 (downloaded the deb file from web site) on Ubuntu Budgie 18.10 and when I try to launch bcompare at the command line I get the following:

    Code:
    Some Shared Libraries were not found
    	linux-gate.so.1 (0xf7f48000)
    	librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf7f18000)
    	libbz2.so.1.0 => /lib/i386-linux-gnu/libbz2.so.1.0 (0xf7f06000)
    	lib7z.so => /home/drohm//lib/beyondcompare/lib7z.so (0xf7cd5000)
    	libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7cb3000)
    	libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7ad2000)
    	libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf7acc000)
    	libQt4Pas.so.5 => /home/drohm//lib/beyondcompare/libQt4Pas.so.5 (0xf78b2000)
    	libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xf7766000)
    	libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xf7747000)
    	libstdc++.so.6 => /usr/lib/i386-linux-gnu/libstdc++.so.6 (0xf75c0000)
    	libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf75a0000)
    	/lib/ld-linux.so.2 (0xf7f4a000)
    	libQtGui.so.4 => not found
    	libQtNetwork.so.4 => not found
    	libQtCore.so.4 => not found
    	libxcb.so.1 => /usr/lib/i386-linux-gnu/libxcb.so.1 (0xf7572000)
    	libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf746c000)
    	libXau.so.6 => /usr/lib/i386-linux-gnu/libXau.so.6 (0xf7468000)
    	libXdmcp.so.6 => /usr/lib/i386-linux-gnu/libXdmcp.so.6 (0xf7461000)
    	libbsd.so.0 => /lib/i386-linux-gnu/libbsd.so.0 (0xf7443000)
    Previous to this latest version 4.2.8, I had 4.2.6 working fine on same version of operating system. After getting this error, I removed 4.2.8 and tried installing 4.2.6 and now it's giving the same error. Can anyone point me to which libraries I need to install and how I can get past this?

  • #2
    We haven't tested Beyond Compare on Ubuntu Budgie 18.10.

    On Ubuntu 18.10 (Gnome), the following command will install required dependencies:
    Code:
    sudo apt install libaudio2 libmng2 libmysqlclient20 libqt4-dbus libqt4-declarative libqt4-network libqt4-opengl libqt4-script libqt4-sql libqt4-sql-mysql libqt4-xml libqt4-xmlpatterns libqtcore4 libqtdbus4 libqtgui4 libqtwebkit4 mysql-common qdbus qt-at-spi qtchooser qtcore4-l10n
    Chris K Scooter Software

    Comment


    • #3
      Hello,

      I just ran through setting up Ubuntu 18.10, installing BC 4.2.6, rebooting, and then installing the 4.2.8 deb from our website. All of this was tested in a 64bit environment with 64bit debs. I didn't hit the same dependency errors in my testing, but if from a Terminal you run a combination of sudo apt-get update and then sudo apt-get upgrade were there any queued up changes/updates for your system that weren't applied? Just to be sure I'm completely up to date, I'll sometimes run those commands alternating, a couple of times each, just to make sure I have all updates applied.
      Aaron P Scooter Software

      Comment


      • #4
        Thanks for the help guys. I figured out what the issue was. Before I installed using the deb file, I originally was using the tar.gz manual installation method (I was using Solus prior to moving back to Ubuntu) and had moved the bcompare.sh script into my ~/bin folder. It was using that script to launch BeyondCompare and was getting confused. I removed all remnants of the local tar.gz install and installed 4.2.8 fresh and it worked perfectly. Again, thanks for all the help.

        Comment

        Working...
        X