No announcement yet.

BC4 files vanished in move - anyway to recover?

  • Filter
  • Time
  • Show
Clear All
new posts

  • BC4 files vanished in move - anyway to recover?


    been a long time user of beyond compare and this is the first issue I've encountered - so well done!
    - but if you have any suggestions for what I can do with the following problem I would be grateful

    In short I tried to "move" some files to an external USB HDD to make space and they never went over
    - they simply vanished from both sides
    I have tried recreating this with a couple of small files and the transfer worked; the transfer that failed was about 13GB made up of about 15 files (installers for SDKs)

    I am running beyond compare 64bit version 4.2.3 on Ubuntu 16.04 LTS running in a VirtualBox VM
    The USB of the external hard drive is passed through to the VM

    Any suggestions as to where these might have gone - or how to recover them would be great.


  • #2
    This isn't an error we've encountered before.

    Did Beyond Compare display any errors in the log pane at the bottom of the Folder Compare when the files failed to move?

    We use VMWare Workstation 14 on Windows hosts in our office, so my knowledge of VirtualBox is limited. VirtualBox's Troubleshooting documentation says each VM should have a log in $HOME/VirtualBox VMs/{machinename}/Logs/VBox.log. Do you see any errors in the log file around the time the move failed?

    On Windows I usually recommend Recuva for simple deleted file recovery. I've never had to recover deleted files on Linux, so I can't suggest a specific tool. A quick Google search for Linux deleted file recovery turned up a tutorial for TestDisk, it might be worth trying.

    If the files are very important, you can also consider a paid deleted file recovery service. Gillware is one such service located in the same city as the Scooter Software offices. We haven't had to use them ourselves, but they have a good reputation.
    Chris K Scooter Software


    • #3
      Chris, I don't know if this will be helpful but I have noticed similar behavior on Linux Mint when renaming a directory using F2 in BC 4. I can't recall if I saw this in BC 3. It is very rare and not reproducible but perhaps 2 or 3 times over the last 2 years when renaming a directory all the files are removed when a directory is renamed.

      Lucky for me I had backups.


      • #4

        Thank you for sharing the report. I'm not aware of any other reports of files being lost when renaming on Linux.

        Were errors displayed when the rename failed?

        In case there's a simple explanation for files that aren't visible after a copy or move, it might be helpful to turn on View > Suppress Filters to make sure they aren't filtered out rather than missing.
        Chris K Scooter Software


        • #5
          The directory was renamed successfully, it was just empty after the rename. No errors.
          Again, it is rare and not reproducible. It does seem to have always been on an external USB drive.