No announcement yet.

BC 4.2.3 Segmentation Fault starting up on Xubuntu 17.04

  • Filter
  • Time
  • Show
Clear All
new posts

  • BC 4.2.3 Segmentation Fault starting up on Xubuntu 17.04

    I just rebuilt my Linux server that I run Plex Media Server on with Xubuntu 17.04. I reinstalled Beyond Compare 4.2.3 and my license then went to run it. I happened to be running as root inside my Terminal window and BC started right up (by typing bcompare in the terminal). I then installed the license and then exited the app. I then exited root in my terminal and tried to start BC without root permissions and got a Segmentation Fault. I tried it a couple more times and got the same results. I then uninstalled BC and reinstalled it and got the same result.

    Is Beyond Compare 4.2.3 compatible with Ubuntu/Kubuntu/Xubuntu 17.04? It was running fine on Xubuntu 16.04 up until I rebuilt my machine today.

  • #2

    Uninstalling does not remove the current settings, so you'll need to navigate to your .config/ folder and manually remove the BCState.xml and other setting .xmls, and BC4Key.txt. If you delete all of these files, does the program launch?
    Aaron P Scooter Software