Announcement

Collapse
No announcement yet.

Question marks (unknown characters) in file sizes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question marks (unknown characters) in file sizes

    Question marks (unknown characters) in file sizes: see the screen-shots attached to the post!
    Attached Files

  • #2
    Hello,

    In your file Explorer, what character is shown/used for that delimiter?

    What are your current Regional Settings? And which Linux OS are you currently running?
    Aaron P Scooter Software

    Comment


    • #3
      Code:
      [19:28:56] janis@janis-desktop /etc $ cat /etc/default/locale
      LANG="lv_LV.UTF-8"
      LANGUAGE="lv_LV:lv"
      LC_NUMERIC="lv_LV.UTF-8"
      LC_TIME="lv_LV.UTF-8"
      LC_MONETARY="lv_LV.UTF-8"
      LC_PAPER="lv_LV.UTF-8"
      LC_IDENTIFICATION="lv_LV.UTF-8"
      LC_NAME="lv_LV.UTF-8"
      LC_ADDRESS="lv_LV.UTF-8"
      LC_TELEPHONE="lv_LV.UTF-8"
      LC_MEASUREMENT="lv_LV.UTF-8"
      [19:29:02] janis@janis-desktop /etc $ cat lsb-release 
      DISTRIB_ID=LinuxMint
      DISTRIB_RELEASE=17
      DISTRIB_CODENAME=qiana
      DISTRIB_DESCRIPTION="Linux Mint 17 Qiana"
      It's hard to find a separator example, as the file explorer displays the size in KB, MB etc, so most (if not all?) sizes do not go above three digits. But if I view a file's properties, it says, for example, "Size: 106,7 KiB (109*236 bytes)".

      (Update) Hmm... That's odd. I do not see the asterisk there. Neither in the explorer, nor here in the editor when I copied the string "106,7 KiB (109*236 bytes)". But it appeared upon submitting the post only.

      (Update 2) OK, it is non-breaking space: https://unicode-table.com/en/00A0/ (bytes C2A0).
      Last edited by Jānis; 08-Mar-2017, 11:46 AM.

      Comment


      • #4
        Thanks for that information. I'll open a tracker entry to investigate. This seems to be a specific issue with Linux Mint and setting the Region to Latvia
        Aaron P Scooter Software

        Comment


        • #5
          I see the same on Ubuntu 16.04 LTS, with Norwegian settings.
          The workaround is to run the following command before running bcompare: export LC_NUMERIC=en_US.UTF-8

          Originally posted by Aaron View Post
          Thanks for that information. I'll open a tracker entry to investigate. This seems to be a specific issue with Linux Mint and setting the Region to Latvia

          Comment

          Working...
          X