Announcement

Collapse
No announcement yet.

External converter in file type not working.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • External converter in file type not working.

    Using Version 4.1.9 (build 21719) on linux.
    uname -a
    Linux QNXWS9600-VM 3.16.0-4-amd64 #1 SMP Debian 3.16.36-1+deb8u2 (2016-10-19) x86_64 GNU/Linux


    When I specify an external converter and try to use it in text compare. I see the message in the bottom left

    'External program "/bin/bash" not found'

    it is however there and is executable
    ll /bin/bash
    -rwxr-xr-x 1 root root 1006K Nov 13 2014 /bin/bash*

    This was working, is this a known issue?

    Is there somewhere that would give me more info on what is going wrong here.

    Thanks

  • #2
    Which external converter is this?

    I had some problems getting an external converter working on Linux, but eventually had success, as detailed here: https://secure.scootersoftware.com/v...rmat-for-Linux

    Comment


    • #3
      No one in particular. I have various listers I use. I've been on win lately and haven't used the linux version, so I was surprised when they no longer seem to work.

      Thanks for the link, but it doesn't help me. I already made sure it was executable and to use absolute paths.
      Not my first pony show.

      Comment


      • #4
        I tested a simple conversion file format using BC 4.1.9 on Ubuntu 16.04 64-bit, it worked without issue.

        The problem might be specific to your conversion program or your file format settings.

        What is the Loading value in your file format?

        What program are you trying to run?

        The following simple test format worked on my system:

        Loading: /home/scooter/test.sh %s %t

        Contents of test.sh:
        #!/bin/bash
        echo $1 > $2
        Chris K Scooter Software

        Comment


        • #5
          Hi!

          'External program "/bin/bash" not found'
          This sounds to me like wrong line endings in the script file.
          Please check if the file has Windows or Linux line endings.

          Using a program like dos2unix could fix the problem ...

          Bye
          Christoph

          Comment

          Working...
          X