Announcement

Collapse
No announcement yet.

Running 'bcompare' "as root"

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Running 'bcompare' "as root"

    Hi, I've poked around to see if I could see anything related to this but came up empty. I'd like to run 'bcompare' "as root" (either via a root shell or via sudo) in order to compare several directories that have root/restricted permissions. When I try to do this I get a blank (grey) bcompare window (see the included screenshot); obviously starting 'bcompare' from a normal user works fine.

    I'm running bcompare v4.1.1 on Fedora 22.

    Thanks.
    Attached Files

  • #2
    I duplicated the blank window problem on Fedora 22 when BC is running as root. This is a bug in Fedora 22, not a bug in Beyond Compare.

    Fedora 23 and CentOS 7.1 both display BC 4.1.1's window correctly when launched from a root terminal.

    You should upgrade to Fedora 23 if you want to resolve this bug.
    Chris K Scooter Software

    Comment


    • #3
      I duplicated the blank window problem on Fedora 22 when BC is running as root. This is a bug in Fedora 22, not a bug in Beyond Compare.
      Thanks Chris. Fedora 23 only just came out and I'm not in a position to upgrade yet. Can you please elaborate on the F22 bug and/or provide information on whether there might be a [F22] workaround?

      Comment


      • #4
        The Fedora 22 bug is: KDE root apps fail to render using X w/o root rights

        To run Beyond Compare as root on Fedora 22 without the screen blanking, run the following commands in a terminal:

        su
        export QT_GRAPHICSSYSTEM=native
        bcompare
        Chris K Scooter Software

        Comment


        • #5
          Thanks Chris, this works fine for me!

          Comment


          • #6
            Originally posted by Chris View Post
            The Fedora 22 bug is: KDE root apps fail to render using X w/o root rights

            To run Beyond Compare as root on Fedora 22 without the screen blanking, run the following commands in a terminal:

            su
            export QT_GRAPHICSSYSTEM=native
            bcompare
            I'm having the same problem with Ubuntu 18.04.1 LTS.

            Running
            Code:
            sudo QT_GRAPHICSSYSTEM=native bcompare
            is a workaround.

            Comment


            • #7
              Originally posted by Chris View Post
              I duplicated the blank window problem on Fedora 22 when BC is running as root. This is a bug in Fedora 22, not a bug in Beyond Compare.

              Fedora 23 and CentOS 7.1 both display BC 4.1.1's window correctly when launched from a root terminal.

              You should upgrade to Fedora 23 if you want to resolve this bug.


              I know this is an old thread, but I'm experiencing the same problem with fedora 28. i've tried the export workaround listed in other commets with no luck. Are there any other options for resolving this problem, or workarounds for the interim?

              Comment


              • #8
                Fedora 28 uses Wayland instead of X11 by default, which doesn't allow graphical applications to run as root/sudo.
                https://ask.fedoraproject.org/en/que...rted-nautilus/

                Workaround:
                Logout, then click on the gear icon and select Gnome on Xorg to run using X11 instead of Wayland.
                Launch Beyond Compare as root with the terminal command: sudo QT_GRAPHICSSYSTEM=native bcompare
                Chris K Scooter Software

                Comment

                Working...
                X