Announcement

Collapse
No announcement yet.

BC 4.1 Loading network drive fails: Value too large for defined data type

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • BC 4.1 Loading network drive fails: Value too large for defined data type

    Beyond Compare 4.1 32-bit running on Ubuntu 14.04 64-bit fails to load SMB/CIFS mounted network drives with the error: Value too large for defined data type.

    To fix the issue, uninstall the 32-bit version of Beyond Compare 4.1 and install the 64-bit version.

    Fix instructions for Ubuntu 14.04 64-bit:
    sudo apt-get remove bcompare:i386
    sudo apt-get install gdebi
    sudo gdebi bcompare-4.1.1.20615_amd64.deb

    This bug is not in Beyond Compare 4.0.7 or earlier, it also doesn't affect Beyond Compare 4.1 32-bit running on 32-bit Linux.

    Another workaround is to load network drives by typing the URL "smb://user@server/share" into Beyond Compare's path edit and hitting Enter rather than mounting a network share with the mount command.
    Chris K Scooter Software

  • #2
    'Salve' to all! I am using Your Beyond Compare Trial Version 4.1.1 (build 20615) (2nd day of 30) on UBUNTU 15.10, i386, 32bit. I was interested to your software while I was trying to rescue data from a Synology DS214play crash. I mounted the TWO hard drives of my NAS and ubuntu recognized it as a device 1.42.6-5565. When I use bCompare for recover files from my SOURCE: TWO 3TB. Toshiba DT01AC300 Hard Disks RAID to my TARGET: 1 TB. Samsung HM100UI Hard Disk everything has worked extremely fine!! (I really felt in love with Your software because is that one I was searching for a long time) ... but, with the function "UPDATE RIGHT" (copy from SOURCE to TARGET), I got some errors on BIG FILES copy operations, on LONG PATH:
    "VALUE TOO LARGE FOR DEFINED DATA TYPE"
    I tried to copy the same files with the included FILE program in UBUNTU and I got a copy from SOURCE to TARGET with NO errors.
    Thank You in advance.

    Comment


    • #3
      This had been fixed in the current release (4.1.3)
      ZoŽ P Scooter Software

      Comment

      Working...
      X