Announcement

Collapse
No announcement yet.

BC4 slowness on kernel 4

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • BC4 slowness on kernel 4

    Just upgraded to Fedora 22, and BC4 is very laggy. strace shows a ton of EAGAINs -- not sure if that's the problem:

    Code:
    recvmsg(6, {msg_name(0)=NULL, msg_iov(1)=[{"\1 \340\351\0\0\0\0}\1\0\0\10\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", 4096}], msg_controllen=0, msg_flags=0}, 0) = 32
    recvmsg(6, 0x9446154, 0)                = -1 EAGAIN (Resource temporarily unavailable)
    recvmsg(6, 0x9446154, 0)                = -1 EAGAIN (Resource temporarily unavailable)
    ioctl(4, FIONREAD, [0])                 = 0
    recvmsg(6, 0x9446658, 0)                = -1 EAGAIN (Resource temporarily unavailable)
    select(9, [6 7 8], [], [], {0, 6986})   = 0 (Timeout)
    ioctl(4, FIONREAD, [0])                 = 0
    ioctl(4, FIONREAD, [0])                 = 0
    recvmsg(6, 0x9446658, 0)                = -1 EAGAIN (Resource temporarily unavailable)
    select(9, [6 7 8], [], [], {0, 99637})  = 0 (Timeout)
    I posted a demo here: https://www.youtube.com/watch?v=jEvjmR_m63Y

    You can see that comparing a 100 line file takes 5 seconds. Even saving takes 1-2 seconds. I didn't show a folder scan, but that is oppressively slow for a folder structure containing about 2000 files.

    The disk is a large (80% free) local SSD. Everything flew in Fedora 20. I'm not having performance issues with any other apps.

    I'll try 4.1, but in the meantime, hope someone knows what's wrong!

    bcompare.i386 4.0.7-19761
    kernel.x86_64 4.0.5-300.fc22

  • #2
    Hello,

    BC 4.1 has fairly extensive changes which may impact this performance, and will replace our older 4.0.x build method. If you could test this beta build (which includes native 64bit support), and let us know how it works for you that would help us know if this is still an issue.

    You can back up your current 4.0.7 settings using the Tools menu -> Export, in case you need to uninstall and rollback to 4.0.7.
    Aaron P Scooter Software

    Comment


    • #3
      Thanks for the quick reply, Aaron.

      4.1 is also suffering from the lag. Let me know how I can help (I'm a developer, as I assume most of your customers are )

      bcompare.x86_64 4.1.0-20251

      Comment


      • #4
        I setup a test VM with a fresh Fedora 22 install, then installed all available updates and the BC 4.1 64bit rpm. I'm seeing a little slowdown but nothing quite like you are seeing in that clip. Are there any driver updates or OS updates which might help? What type of devices are the left and right base folders; local to the hdd or a remote share?
        Aaron P Scooter Software

        Comment


        • #5
          I also tried a fresh F22 vm (using both Gnome and Cinnamon) and it works great. Hmm.

          I'll report back when I figure it out.

          Comment


          • #6
            Hi,
            I'm also experiencing a *major* slowdown in BC4 when Fedora upgraded to kernel 4.x
            I'm using Fedora 22, but I saw it also on Fedora 21 (once they upgraded to the kernel 4.x)
            Comparing a simple file can take up to 7-8 seconds, as opposed to below a second before.

            Comment


            • #7
              I wanted to let you know that with the 4.1.0-20251 beta, the problem disappears on my computer.
              I'm using Fedora 22, kernel 4.0.5-300

              Comment


              • #8
                hi

                i am using a fedora 22 Linux i7 4.0.5-300.fc22.x86_64 lxde
                and after suffering slowness with 4 i tried Version 4.1 beta (build 20251) and its great,, keep up the good work.

                @gsheremeta : if you want i can test your files if you provide download links.

                Comment


                • #9
                  I have also noticed BC4 has got slow recently on Linux. I am not sure it it is due to the kernel version a new version of BC4. (I am running Ubuntu 15.05 Vivid with a 3.19 kernel).

                  However, I recently installed the latest BC4.1 beta, and all the performance problems disappeared. Comparisons that used to take 5-10 seconds to load now take less than a second, so if you can, I would suggest you try the latest beta.

                  Comment


                  • #10
                    One more data point: I was experiencing the same slowness problem and seeing the same EAGAIN errors from strace. Running Ubuntu 15.04 with 3.19 kernel, 64-bit. The 4.1.0-20431 beta package fixed the problem for me - I have near instant diffs again!

                    Comment

                    Working...
                    X