Announcement

Collapse
No announcement yet.

Error in using BC 3 pro in LINUX

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error in using BC 3 pro in LINUX

    Error in using BC 3 pro in LINUX while comparing 2 files.

    /usr/lib/beyondcompare/BCompare kps1 kps2
    /usr/lib/beyondcompare/BCompare: error while loading shared libraries: libqtc.so.1: cannot open shared object file: No such file or directory

    Please provide me resolutions steps to resolve this issue in detail

  • #2
    Hello,

    Which version of Linux are you running, and are you running in an environment that supports XWindows? BC3 is tested for these versions:
    http://www.scootersoftware.com/download.php?zz=kb_linux

    It also requires XWindows, and would not support running from an SSH connection without the necessary XWindows setup. To test this: instead of running BCompare, can you run Firefox? If the Firefox interface can launch and display, that likely means XWindows is setup.

    If you are still having any trouble, how did you install Beyond Compare? Depending on your distro, I recommend the .rpm or .deb to get dependency management.
    Aaron P Scooter Software

    Comment


    • #3
      Also, it looks like you are calling the base executable directly (/usr/lib/beyondcompare/BCompare). The expected use is to call the public executable /usr/bin/bcompare executable (which after setting up the correct environment will call /usr/lib/beyondcompare/BCompare).

      So try:
      bcompare kps1 kps2
      David J Scooter Software

      Comment

      Working...
      X