Announcement

Collapse
No announcement yet.

BC4 not starting at all unter Kubuntu 12.04 (64 bit)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Aaron
    replied
    Hello,

    There are a couple of misunderstandings in this post I'll try to help clear up.

    First is that Beyond Compare 4 is a 32bit application that can run on 32bit and 64bit OS's. This is true on Windows, Mac, and Linux. Some OS's are better about their 32bit support than others, but we've found all major versions of Linux have robust support for 32bit applications on 64bit variants. We've tested on both, and I generally run 64bit test environments.

    The "64bit".deb you found is an old mechanic that was required by older versions of 64bit linux. The included application is still 32bit, but the .deb itself needed to be marked as "64bit". It's a label that it's to be installed on 64bit distros, and not that the included app is 64bit. However, newer versions of debian changed this behavior and allow the easy install of 32bit applications. The old download is a legacy download for users still on older distros.

    Ubuntu 14.04 should use the main 32bit.deb download.

    Native 64bit support is on our wishlist, but our current toolset limits the ability to simply rebuild as 64bit. For a more detailed, technical explanation, we have a post here:
    http://www.scootersoftware.com/vbull...1349#post41349

    Leave a comment:


  • intersol
    replied
    Can you please provide a real x64 build so we do not spend hours trying to make it work on Linux?

    I am surprised that you do not have a x64 build, considering that nowadays, most OS-es are dropping the 32bit support.

    Update: it seems that there is an x64 build, but is not listed on http://www.scootersoftware.com/download.php page... probably you missed to update the page?

    ... it seems that ia32-libs is required but it doesn't exist un Ubuntu 14.04... clearly not the best deployment experience.

    Damn, i spend more than an hour trying to make it work and I am risking on affecting the stability of the server where I want to install it.

    Clearly BeyondCompare requirements page is incorrect, the support for running on x64 Ubuntu is broken badly.
    Last edited by intersol; 11-Nov-2014, 05:02 AM.

    Leave a comment:


  • Chris
    replied
    mackyy20,

    The problem might be an issue with your user settings. To test for this, move the contents of ~/.config/bcompare/ to a backup folder, then try running Beyond Compare. This will make Beyond Compare create a new set of default settings.

    Leave a comment:


  • mackyy20
    replied
    On a other machine a test version of BC3 works without any problems. I don't know the cause, but it's under the same OS as my notebook, were BC doesn't work.

    Before I got the hint to try BC4 I had the same issue with BC3.

    Today I found out, that BC4 runs without any problems if I execute it as root!

    Leave a comment:


  • David
    replied
    Good. Thanks for letting us know.

    Leave a comment:


  • armakuni
    replied
    David, the script placed in /usr/bin/bcompare already handles the LD_LIBRARY_PATH correctly, if it's defined already before.

    I did as you suggested and copied the libfreetype.so.6.8.0 to /usr/lib/beyondcompare and created a symlink named libfreetype.so.6 here.

    My first solution was this:

    I did the following:

    I downloaded the original libfreetype6.so packages for my particular Ubuntu distro (here: precise) for i386.
    I unpacked the libfreetype.so.6.8.0 to a new directory, here $HOME/.local/opt/goodfreetype/i386/ .
    After this I created a symlink from libfreetype.so.6.8.0 to libfreetype.so.6

    Now I create this script file:

    Code:
    #!/bin/sh
    
    export LD_LIBRARY_PATH=$HOME/.local/opt/goodfreetype/i386/
    bcompare "$@"
    save this as bcompare4.sh for example and chmod u+x it.

    Now I can start Beyond Compare 4 without any problems.

    The only disavantage is that I cannot use the "compare" options in Dolphin's right click menu with this because the LD_LIBRARY_PATH.
    But with your solution this works

    Leave a comment:


  • David
    replied
    Keep in mind that to allow Beyond Compare to find our versions of the Qt libraries (libqtc.so & libqt-mt.so) we set LD_LIBRARY_PATH=/usr/lib/beyondcompare in the /usr/bin/bcompare startup script (or where ever it was place on your distro). So you could place the libfreetype6.so in the same location as the libqtc.so and libqt-mt.so (i.e. /usr/lib/beyondcompare). Or if in another location then both locations need to be in LD_LIBRARY_PATH.

    LD_LIBRARY_PATH=/usr/lib/beyondcompare:$HOME/.local/opt/goodfreetype/

    Leave a comment:


  • armakuni
    replied
    Aaron, I fully agree with your description.

    As already mentioned, I try the maintainers suggestion in the next time and give feedback if it helps.

    Leave a comment:


  • Aaron
    replied
    Thanks. Looking into that project, it is a sufficiently a complicated setup and non-standard that we cannot support it. The crash is within an area that is no longer our code, so whatever is happening is not within Beyond Compare but based around a modification this package has likely performed. I would recommend the maintainers suggestion and set Beyond Compare to use the regular libraries if that is an option.

    Leave a comment:


  • armakuni
    replied
    Hi,

    today I got a hint from the maintainer of the Infinality PPA package. If some application run into problems with Infinality font patch, it's possible to use the regular libfreetype6.so file:

    Basically you just need to download the regular freetype6 deb and unpack the libfreetype6.so to some directory.

    Then I just prefer that directory with LD_LIBRARY_PATH.

    E.G.

    whatever_fixed.sh:

    ```
    #!/bin/sh
    export LD_LIBRARY_PATH=$HOME/.local/opt/goodfreetype/
    whatever "$@"
    ```
    I already uninstalled Infinality from my machine. I could test this in the next days (or weeks) on a second machine where Infinality actually remains installed. Otherweise I would set up a virtual machine for this for testing. But maybe you can test it too, if you already have an approbiate test machine for this.

    Leave a comment:


  • armakuni
    replied
    Ok guys,

    I definitely found out that this issue is caused by the Infinality font rendering engine. I provided already links for you to read and test this package, if you want.

    As I am still waiting for my account approval at the Infinality board, I decided yesterday to drop the Infinality package and replace it with the Ubuntu default freetype rendering engine, short: I removed the PPA and all associated packaged to it and reverted to the default version

    Code:
    [DOWNGRADE] libfreetype6:amd64 2.4.12-0ubuntu0ppa1infinality20130515 -> 2.4.8-1ubuntu2.1
    [DOWNGRADE] libfreetype6:i386 2.4.12-0ubuntu0ppa1infinality20130515 -> 2.4.8-1ubuntu2.1
    After a restart I tried BC4 and it runs smooth so far (I didn't try everything yet, only starting and invoking the Option screen). It used my ~/.qt/qtrc file correctly which was created with qtconfig. Normally, I don't need qtconfig with KDE, because KDE has it's own settings for desktop visual style, which has a option to copy these settings for KDE3 or pure Qt3 Apps. In this case KDE creates an approbiate ~/.qt/qtrc file with the chosen style settings.

    I tried this too and BC4 is running fine.

    We can say now that BC3 and BC4 (or maybe the Qt3 components from it) doesn't work well with Infinality font patches. I'm a bit wondering about this, because with some particular settings it worked. But I don't have the time to test every Infinality setting for the cause, and as long as I don't have contact to the Infinality developer this probably doesn't make much sense.

    Maybe you can find something here causing this, but actually it looks like I am the only one who ran into this issue, therefore it's probably no need for further investigation into this.

    I'm very thankful for your help and patience.

    Now I can begin my trial period with BC4 ;-)

    Leave a comment:


  • armakuni
    replied
    Another thing: Maybe I was a bit so fast with my positive news. If I try to open the options screen, BCompare crashes with a Runtime Error 231. I can see this if invoking bcompare from a terminal screen

    Leave a comment:


  • armakuni
    replied
    Ok, I was able to pinpoint the cause.

    I have installed the Infinality font patches, which improve the renderings of freetype engine. There are some options to select from predefined rendering profiles. In particular this means that you can change font rendering to behave like Windows 7, Windows 98, Mac OS X or like Linux.

    If I set font rendering to "Windows 98" - which is very ugly because it doesn't use any subpixel rendering - I can successfully start Beyond Compare!

    I recreated my qtrc file with qtconfig after successful run and it will be used. Some fonts aren't loved by BC (or Qt?) and let it crash, but it's changeable.

    I would like to contact the author of the Infinality patches, unfortunately he's manually activating registrations to his board and I'm already waiting for some days. Maybe it's possible to pass specific rendering settings to BC.

    / EDIT: Sorry, I should've added additional infos on this.

    You can find a PPA for Ubuntu distros here: https://launchpad.net/~no1wantdthisn...ive/ubuntu/ppa
    And here is the main page: http://www.infinality.net/
    Last edited by armakuni; 31-Aug-2014, 09:58 AM. Reason: Added additional infos

    Leave a comment:


  • armakuni
    replied
    Originally posted by Dave_L View Post
    Another easy thing to try is to create another normal, non-privileged user account, and see if BC can be run by that user. That's just to eliminate the possibility that your current user account has something odd in its configuration.
    I didn't look if I already mentioned this, but with another (fresh) account it's the same issue.

    Leave a comment:


  • Aaron
    replied
    Excellent idea, Dave. Thanks!

    Leave a comment:

Working...
X