Announcement

Collapse
No announcement yet.

bcompare-3.3.8.16340 install errors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • bcompare-3.3.8.16340 install errors

    After using install.sh to install bcompare, I got the following error when I tried to run bcompare:
    Some Shared Libraries were not found
    linux-gate.so.1 => (0x00acf000)
    lubz.so.1 => /lib/libz.so.1 (0x002b9000)
    libqtc.so.1 => /home/lynn.jennings/lib/beyondcompare/libqtc.so.1 (0x00532000)
    libX11.so.6 -> /usr/lib/libX11.so.6 (0x00342000)
    librt.so.1 -> /lib/librt.so.1 (0x0017f000)
    libpthread.so.0 => /home/lynn.jennings/lib/beyoundcompare/libqt-mt.so.3 (0x00dba000)
    libXert.so.6 -> /usr/lib/libXert.so.6 (0x00188000)
    libstdc++.so.6 -> /usr/lib/libstdc++.so.6 (0x0019a000)
    libm.so.6 => /lib/libm.so.6 (0x00285000)
    libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00a8e000)
    libxcb.so.1 => /usr/lib/libxcb.so.1 (0x002cf000)
    /lib/ld-linux.so.2 (0x00b95000)
    libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00337000)
    libXrender.so.2 => /usr/lib/libXrender.so.2 (0x002af000)
    libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x002ef000)
    libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x002f9000)
    libXft.so.2 => /usr/lib/libXft.so.2 (0x002fc000)
    libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x0047b000)
    libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00a48000)
    libSM.so.6 => not found
    libICE.so.6 => not found
    libXau.so.6 => /usr/lib/libXau.so.6 (0x00311000)
    libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00314000)
    libexpart.so.1 => /usr/lib/libexpart.so.1 (0x00ad0000)

    Please let me know how to install this program, without root permissions, so that these libraries are accessible.

    Thanks!

  • #2
    The above 'not found' dependencies would need to be resolved and installed on your system. Normally, our installer will install any dependencies needed (although, it might need elevated or root permissions for some).

    Which installer did you run, and which OS are you running, version, and 32bit vs 64bit?

    Can you resolve and install libSM.so.6 and libICE.so.6?
    Aaron P Scooter Software

    Comment

    Working...
    X