Announcement

Collapse
No announcement yet.

bcompare4 repository not available

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • bcompare4 repository not available

    BC 4.0.0.17628
    Ubuntu 12.04.4

    Code:
    $ sudo apt-get update
    ...
    Err http://www.scootersoftware.com bcompare4/non-free amd64 Packages                                           
      404  Not Found
    Err http://www.scootersoftware.com bcompare4/non-free i386 Packages                                            
      404  Not Found
    ...
    W: Failed to fetch http://www.scootersoftware.com/dists/bcompare4/non-free/binary-amd64/Packages  404  Not Found
    
    W: Failed to fetch http://www.scootersoftware.com/dists/bcompare4/non-free/binary-i386/Packages  404  Not Found
    
    E: Some index files failed to download. They have been ignored, or old ones used instead.
    Code:
    $ cat /etc/apt/sources.list.d/scootersoftware.list
    deb http://www.scootersoftware.com/ bcompare4 non-free
    
    $ cat /etc/apt/sources.list.d/scootersoftware.list.save
    # deb http://www.scootersoftware.com/ stable non-free
    Is this intentional, because BC4 is still beta?

    In the meantime, I changed "bcompare4" back to "stable" in scootersoftware.list, to avoid the error.
    Last edited by Dave_L; 06-Feb-2014, 06:17 AM.

  • #2
    Hi Dave,

    We haven't configured the server for apt-get update yet, but this is on our list of things to do for the beta. Thanks for the report.

    In the meantime, you'll need to get updates via the website or Check for Updates.
    Aaron P Scooter Software

    Comment


    • #3
      I have BC4 build 17666 installed on Ubuntu 13.10. I installed bcompare-4.0.0.17628_i386.deb using Ubuntu Software Center. I then used the in app upgrade to build 17666. When I try to upgrade Ubuntu, I get the following error:
      sudo apt-get upgrade
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      You might want to run 'apt-get -f install' to correct these.
      The following packages have unmet dependencies:
      bcompare : Depends: ia32-libs but it is not installable
      E: Unmet dependencies. Try using -f.

      Comment


      • #4
        Originally posted by Aaron View Post
        Hi Dave,

        We haven't configured the server for apt-get update yet, but this is on our list of things to do for the beta. Thanks for the report.

        In the meantime, you'll need to get updates via the website or Check for Updates.
        bcompare-4.0.0.17666_i386.deb again changed /etc/apt/sources.list.d/scootersoftware.list to:
        Code:
        deb http://www.scootersoftware.com/ bcompare4 non-free
        This causes warning messages when upgrading other packages.

        If the repository doesn't exist yet, why does the installer put it in the sources list?

        Comment


        • #5
          Hi,

          i32-libs should only be included with our older "64bit" installer which is no longer supported on newer 64bit os's. Is it possible you have an older BC3 installer which had included it? My recommendation here is to launch the GUI, and use the Tools menu -> Export to export all of your settings. Then uninstall using apt-get to remove ia32-libs dependencies. Then reinstall the latest BC4 beta with the regular (32) .deb. Does this help remove this occurrence?
          Aaron P Scooter Software

          Comment


          • #6
            Sorry, this is currently working this way due to how the project has been brought forward and the installers created. It's a beta issue that we'll definitely work on before 4.0's launch, but we have had other higher priority bugs we've needed to squash (like, getting SFTP support working on OSX).
            Aaron P Scooter Software

            Comment


            • #7
              I didn't have BC3 installed. I removed BC4 and then downloaded bcompare-4.0.0.17677_i386.deb. Instead of using Ubuntu Software Center to install this file, I used GDebi to install it and now I don't have this ia32-libs conflict.

              Comment


              • #8
                Originally posted by Aaron View Post
                Sorry, this is currently working this way due to how the project has been brought forward and the installers created. It's a beta issue that we'll definitely work on before 4.0's launch, but we have had other higher priority bugs we've needed to squash (like, getting SFTP support working on OSX).
                Ok, but I don't understand why changing "bcompare4" back to "stable" in the installer, until the repository actually exists, is that hard to do.

                Comment


                • #9
                  This bug is still present in BC 4.0.0.17887.

                  Comment


                  • #10
                    Correct. We weren't able to get this on fixed in the last release, but we're investigating it now and hope to get it into the next one. If you didn't get a chance, check out the changelog for the last release: it's a doozy (including fixing SFTP on Linux)
                    Aaron P Scooter Software

                    Comment

                    Working...
                    X