Announcement

Collapse
No announcement yet.

Potential new user wondering about old libraries and new versions.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ZoŽ
    replied
    Originally posted by plant-class View Post
    Isn't that the point, that qt4 is around 2011 and long out of date, so even though the license will be valid, it is getting less and less likely BC4 will just keep working.
    We are still releasing updates to BC4 and if our built-in QT4 has compatibility issues before v5 is released we will do what we can to fix or workaround it. The glibc and kernel syscall APIs are generally stable enough, so if we have to include some more prebuilt or statically linked libraries I don’t expect it to be a huge issue.

    Originally posted by plant-class View Post
    Is this the case for full licenses purchased with a discount code? Like the one currently available?
    Yes, upgrade protection applies to licenses bought during our sales.

    Leave a comment:


  • plant-class
    replied
    Thank you for the information.

    so as long as the low level libraries maintain compatibility it should keep running.
    Isn't that the point, that qt4 is around 2011 and long out of date, so even though the license will be valid, it is getting less and less likely BC4 will just keep working.

    The upgrade policy states;

    You only get automatic upgrade protection when you pay full price for a license.
    Is this the case for full licenses purchased with a discount code? Like the one currently available?

    Leave a comment:


  • ZoŽ
    replied
    BC 5 will use QT5. We’re not planning on updating BC4 to do so, though we do include the QT libraries with the install packages now, so as long as the low level libraries maintain compatibility it should keep running.

    We don’t have anything to announce about BC5 release date or features yet though. When it’s released our upgrade policy will apply, which is available at https://www.scootersoftware.com/shop...=upgradepolicy

    Leave a comment:


  • Potential new user wondering about old libraries and new versions.

    Hi there

    Contemplating purchasing a basic license to use on my Arch Linux machines, but note a few issues as arch doesn't seem to be supported.

    My question is qt4 is old, very old and BC4 uses it, is it your plan that BC5 will use qt5, or could this upgrade still be part of a BC4 upgrade?

    Thanks in advance.
Working...
X