Announcement

Collapse
No announcement yet.

Can not use a SSH private key of 3072 bits (RSA, SHA256)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can not use a SSH private key of 3072 bits (RSA, SHA256)

    As the title says, today I find Beyond Compare (4.3.5, build 24893) doesn't support my private key of 3072 bits, RSA.

    This software didn't report any message like "unsupported private key" - it just failed with "No more authentication methods" when I tried to connect to all servers. But I find my another private key which is 2048-bit has worked well for years, so I guess the longer bits caused such an error.

    My private key file is correct since I can use `ssh.exe` of Git for Windows and `/usr/bin/ssh` of WSL 1 with it to connect my servers.

    The file path is correct, too, and I have tested it with a fresh installation of Beyond Compare in a Windows Sandbox environment.

    #### Some tests

    Code:
    ssh-keygen -f gdh1995.servers.id_rsa -l
    outputs:

    Code:
    3072 SHA256:XHATYVAdXZo3YnU5YkMpxV+MrYfNuShZs0gaTpI/5l4 gdh1995@evision.servers (RSA)

  • #2
    Hello,

    Thanks for the feedback. Yes, BC4 is not compatible with some formats/combinations of SSH keys. We have some info here:
    http://www.scootersoftware.com/suppo...vatekey_compat

    If you are on Windows, BC4 does support using Putty's Pageant. If you set up Pageant to handle the newer key pair, does this work for you?
    Aaron P Scooter Software

    Comment


    • #3
      Oh sorry I didn't search the KB page.

      Yes the page helps a lot. I've switched to .ppk key files and now BC4 works well with it. So my assumption about "3072 bits" is wrong.

      Sorry again for wasting your time.

      Comment


      • #4
        Oh, no problem at all. Troubleshooting keys is never a fun experience, so I'm glad I could help.
        Aaron P Scooter Software

        Comment

        Working...
        X