Announcement

Collapse
No announcement yet.

BC 4 Not starting on Windows 10

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BC 4 Not starting on Windows 10

    Hi,

    I'm having an issue starting up BC 4, and it running as it showed in the Task Manager, but the app is not showing.


    I've already tried to uninstall and reinstall and still the same.

    I hope someone can help me.

    Thank you

  • #2
    Are you running an Insider build of Windows 10 (preview release) instead of an official release?

    Beyond Compare failing to display on launch is a known bug caused by Microsoft in Windows 10 Insider build 20150 (fast ring). We reported it using Feedback Hub in Windows 10.

    To increase the priority of the bug, please upvote and/or comment on the report.

    Problem title: Beyond Compare fails to display on Windows 10 build 20150
    Feedback Hub link: https://aka.ms/AA8r9z1

    To workaround the issue until Microsoft fixes it, revert to a stable release version of Windows 10. Beyond Compare 4.3.4 is fully compatible with Windows 10 official releases 1909 and 2004.
    Chris K Scooter Software

    Comment


    • #3
      Upon further investigation, this issue only affects 64-bit versions of Beyond Compare. Forcing a 32-bit install will workaround the issue until Microsoft releases a patch.

      To force a 32-bit install of Beyond Compare on 64-bit Windows:

      From the Start menu, right click on Command Prompt and select Run As Administrator.
      Run Beyond Compare's .exe installer with the /32 command line switch.
      BCompare-4.3.4.24657.exe /32
      If Beyond Compare is already installed, select Upgrade as the install type.

      To determine if your install is 32-bit or 64-bit, run Beyond Compare and open Help > About Beyond Compare.

      To return to a 64-bit install after Microsoft patches this issue:
      Uninstall Beyond Compare.
      Reboot the computer.
      Install Beyond Compare.
      Chris K Scooter Software

      Comment


      • #4
        Thank you!!
        That solved it!

        Comment


        • #5
          I did this but BC no longer opens files when I browse or select multiple files and use the context explorer.
          BC opens but it is just blank, so not much of an improvement! :P I browsed to a file in BC but it didn't update the display.

          Comment


          • #6
            Microsoft has acknowledged the bug in the newest release notes.

            https://blogs.windows.com/windowsexp...w-build-20152/

            Starting with the last build, some games and applications may crash at launch or fail to install. We’ve identified the root cause and are working on a fix for a future flight.
            Chris K Scooter Software

            Comment


            • #7
              Instead of using the context menu, you can drag and drop from Explorer onto the BC4 interface, blank comparison areas or path bars. You can also leave feedback via the Feedback Hub link so MS can hear from their Insider testers and what they need.
              Aaron P Scooter Software

              Comment


              • #8
                Installed using /32 switch. Now BC fails to show Tools Options form. So I ended the task and used the Run As Administrator. Now Tools-Options works.

                Comment


                • #9
                  That may be related to the above Feedback Hub issue; you may want to add your notes as well via the Feedback Hub.
                  Aaron P Scooter Software

                  Comment


                  • #10
                    This issue was fixed by Microsoft in Windows 10 Insider (fast ring) build 20161.
                    Chris K Scooter Software

                    Comment


                    • #11
                      Thank you!

                      Comment

                      Working...
                      X