Announcement

Collapse
No announcement yet.

Forcing BC4 to ignore syntax

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Forcing BC4 to ignore syntax

    Hello,

    I am comparing two xml files. Sometimes I wanna compare the files without using the xml syntax detection. So I have to set manually from "XML Sorted" to "Everything else". The reason is that only the text content and not the syntax is important

    I have prepared a session with the settings and my idea is now to use a batch file like

    Bcompare.exe "SessionEverythingElse" %1 %2

    but this doesn't work. The merge dialogue appears.

    Also

    Bcompare.exe %1 %2

    doesn't work.

    Is there a way to force ignoring the xml syntax detection and comparing the text content only by calling the diff from command line?

    Thanks
    /Michael




  • #2
    Hello,

    Unfortunately, loading the session name on the command line does not support location parameters. If the Session itself contains the targets, then it could use
    bcompare.exe "session name"
    or just the targets, which loads with the default session settings
    bcompare.exe "c:\target1.xml" "c:\target2.xml"

    It's on our wishlist to allow defining a session along with targets, but this isn't supported in the current version.
    Aaron P Scooter Software

    Comment


    • #3
      i have also checked yesterday a way via using script, but BC doesn't support this setting by script right?

      /Michael

      Comment


      • #4
        Unfortunately, not for files.

        If they were Folders, you could script:
        load "session name"
        load "c:\target1" "c:\target2"
        (this would load the session, then load the folders into it).

        For files, you would have to update the program's default settings (either graphically, or manually updating the .xml), and those defaults are then used for the text-report script line.
        Aaron P Scooter Software

        Comment

        Working...
        X