Announcement

Collapse
No announcement yet.

I can't ignore capitalization.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • I can't ignore capitalization.

    BC4 is currently highlighting lines, even when they differ only by capitalization. I want to ignore those.
    • In Session Settings, I have UN-checked the box labeled "Character Case".
    • I have selected the "Minor" button (sub-text: "Ignore unimportant Differences").
    • I have ensured that the file type (.cs file) corresponds to the rules selected (as suggested here).

    What else am I missing?

  • #2
    The character case check box only affects default text (text that isn't a string, identifier, comment, etc).

    To ignore character case for non-default text, click the Edit Grammar button.
    In the Grammar tab, select the grammar definition that matches the text that should ignore character case, such as Identifier.
    Click the Gear icon.
    Uncheck This element is case sensitive.
    Click OK until you're back to the main window.
    Chris K Scooter Software

    Comment


    • #3
      Excellent! That explains it. Thank you for the quick response!

      Comment

      Working...
      X