Announcement

Collapse
No announcement yet.

Folder Sync Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Folder Sync Problem

    SO I bought a TerrMaster NAS and trying to sync folders from some external hard drives and files from my documents folder on a windows 10 computer. For some reason some files will transfer yet are showing as different (purple) when I do a full refresh. I have tried everything as far as permissions and file attributes but still now luck. The crazy thing is that I can completely delete all the files on the NAS and sync them again and different files or non at all have this issue..

    Any suggestions?

    Click image for larger version

Name:	bc.JPG
Views:	119
Size:	94.3 KB
ID:	82386

  • #2
    Hello,

    The screenshot resolution is a bit low, but it appears you have a collection of files reporting with equal timestamps but 'different'. By default, 'differences' are determined by "size", but if you've updated any of the options in the Session Settings, Comparison tab, these would apply. When files are 'different' but timestamps are equal, both are red. A Sync Update doesn't copy these, since a file that is different but with equal timestamps may require human review (how could it be updated or different but with an equal last edit date). A Sync Mirror always copies anything that isn't exactly equal, so it will copy them anyway.

    If you expand the Size column to show more detail by making it wider, are the sizes exactly the same? Sometimes, different protocols (FTP) will store files with a different size (usually, text files with a different line ending).

    What are your current comparison settings, and what is different about these files?

    Purple files are "orpahn" and don't exist on the other side, so a Sync Update or Mirror will always bring them over. A Sync Mirror will also *delete* any Orphans in the destination side, since the Mirror will make the destination a mirrored copy of the source (only leaving equal files alone).
    Aaron P Scooter Software

    Comment


    • #3
      I understand how the programs works and have been using it for several years with sync mirroring onto USB drives that are using NTFS file system. I have recently bought a NAS and its using the Btrfsfor a file system. This is when I get into trouble with BC. I have never had this issue usinf a external hard drive and just started when using BC to sync to this NAS.

      Currently I am trying Microsoft's SyncToy to see if I run into the same issue with syncing to this NAS and new files system. As of now, 5 TB into the sync I have not experienced any issues but I got about 4 TB more togo

      Any ideas about syncing to different file system?

      Comment


      • #4
        Since both sides are red, either the Size column is revealing a difference when wider or the Session Settings have been configured to compare another non-visible criteria. Determining what is causing the difference would help determine why the files need to be synchronized.

        The file system wouldn't likely be a cause, but some NAS devices will do things like 'show the files as equal' and then after a refresh 'reveal that was cached false information, and it is actually different'. It is also important to verify against Explorer, to see what properties it shows immediately after a transfer, and it's Properties dialog on a test file, to see if it matches BC4 behavior immediately after a transfer and BC4's column information Before and After a refresh. This helps troubleshoot if the display is showing incorrect information from the device or correct-changing information, and when.

        There are no purple files in the screenshot, but those should be Orphan (only on one side), so the expected behavior would be to included in the sync/copy.
        Aaron P Scooter Software

        Comment

        Working...
        X