Announcement

Collapse
No announcement yet.

Howto compare 2 files passed via command line but forcing use of specific text format

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Howto compare 2 files passed via command line but forcing use of specific text format

    I have a script which invokes BC passing it the left and right files but it always starts with DETECTED for both - I want it to use a file format that I've defined. How do I do this? I searched but either this question has not been asked or I'm using the wrong key words. I apologize if it has been asked.

  • #2
    Hello,

    The command line does not support forcing a specific file format for two files. Is your script working on the Folder level and generating a report on the folder or file level? Or is it directly on the file level? The Folder Level session compare could be configured to save with a specific File Format list only for that session, which could have only your specific new format enabled (*.*), while the normal global options has this format disabled.
    Aaron P Scooter Software

    Comment


    • #3
      Can I ask that an explicit File Format command line option be added to a future version? Sometimes the needed file format can't be determined by the file extension and in the case of FTP there isn't any file extension in my case (IBM Mainframe).

      Comment


      • #4
        It is something on our wishlist, but not a feature we'll be able to tackle short-term. I'll add your notes to our entry on the subject.

        As a possible workaround, if you create a new Format in the File Formats dialog (perhaps a clone of an existing format), then assign it for *.* (all files) and disabled it (uncheck it).

        Then, in a saved Folder Compare session, go to the Session Settings, Misc tab, and uncheck all other formats and enable the new format (for *.*). For this session, all files will then use this one format, while the global defaults will not use it automatically.
        Aaron P Scooter Software

        Comment

        Working...
        X