No announcement yet.

"the system cannot find the path specified"

  • Filter
  • Time
  • Show
Clear All
new posts

  • "the system cannot find the path specified"

    Windows 10, problem started yesterday. I don't remember the exact error message, but upon researching I found a tip to change the drive letter. So I changed the drive letter from D to Z and that issue seemed to resolve.

    Now I am getting "Failed to synchronize x items. ...Lst error: Unable to create E:\Pictures...:The system cannot find the path specified. As far as I know this was never labeled Drive E.

    I also get: Successfully synchronized 11 items. Failed to syndronize 217 items.
    Last error: Unable to copy Z:\pictures...: The system cannot find the path specified.

    I can manually copy the failures to the other drive. When I then run Refresh it still shows the files missing from the drive they've been copied to.

    Any thoughts or suggestions?

  • #2

    Have you rebooted your system since changing drive letters?

    Also, what type of device is assigned the drive letter? Is this an external usb drive? Internal hard drive? Network or another bound drive? If external hardware, I would recommend power cycling it off for 5 minutes while you reboot your machine, too.

    After you manually copy to the other drive, then run refresh it shows the files as missing. After a reboot, are the files still present in Explorer or missing? Are they present or missing in BC4?
    Aaron P Scooter Software


    • #3
      Yes, I rebooted the system and disconnected the drives after changing the drive letter. These are both external hard drives (2TB and 4TB).

      The files are present in Explorer, just not showing up in BC4.

      Now I remember what the original issue was. Today I got error messages that there was an I/O error. In researching that, I found the tip to change the drive letter, and that was successful for a time.

      This morning when I was again trying to synch files I got an I/O message that some files couldn't be synched. I turned BC4 off with great difficulty, almost had to do a hardboot on the computer. Then I launched BC again and this time it won't load the drive at all. At first I got a message Z not available, I/O error. (in trying to copy the exact message, I inadvertently hit OK, and that error message disappeared. When I tried again, I got a "Folder Not Available, Z:\ in the command field.


      • #4

        Thanks. In addition to disconnecting, I would also suggest power cycling them, too, just in case either is in a bad state. These are not error messages or workarounds I'm familiar with, so I am concerned about that hardware.

        If you use the Windows Command line and navigate to the folder, can the command line "dir" the listing of the directories and see the items?
        I would also recommend disconnecting and powering off one of the drives entirely, and test with a local to usb transfer. With a few tests, we can hopefully limit the issue to either the Source USB drive or the Destination USB drive that is causing the error.
        Aaron P Scooter Software


        • #5
          Sorry, I've been doing other things. I always turn my laptop off, disconnect all attached drives, reboot with no attachments, and then restart BC4. Today, I tried synching about 8 folders and got the can't find the path message and again had a hard time turning off the program. Then I again tried synching each folder separately and that worked, whereas it hadn't before. I finally got to one folder with one file that is gumming up the works. Do not know what the issue is, but I can't turn BC4 off and am going to have to do a hard boot, as nothing else is working. It appears all these issues may be related to one bad file.


          • #6

            Specifically, you mention powering off your laptop and disconnecting the drives, but are the drives externally powered? If so, it would be important to power them off as well as part of this troubleshooting, and let them fully discharge (leave disconnected) for 5+minutes.

            If there is a problem file, we can try using lower base folders to narrow down which base folder it is in. File Name Filters might also help, but excluding sections to find fully working subfolder sets or problem subfolder sets. Filters like:

            One bad file is generally not enough to bring the whole system down. I suspect it's a combination of a bad file and one of the external devices handling it poorly. One other tip when dealing with externals: if you have an alternate cables you can test, a bad cable can cause general weirdness, and is worth a swap as a troubleshooting step.
            Aaron P Scooter Software