Announcement

Collapse
No announcement yet.

Issues comparing W7 to Linux via sftp: Equal text files shown as different.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issues comparing W7 to Linux via sftp: Equal text files shown as different.

    To reproduce:
    On Windows create a folder TEST (e.g. %TEMP%\TEST ), create a new empty text file "test.txt" within that folder and add some lines with Notepad
    On Linux create a folder TEST (e.g. /tmp/TEST )

    Now start Beyond compare
    Left path : %TEMP%\TEST
    Right path : sftp://user@ipaddr//tmp/TEST.

    As expected you'll see a folder with file on the left side and an empty folder on the right side.
    Now copy the file from left to right. BIG SURPRISE, THE FILE IS SHOWN AS DIFFERENT.
    Click image for larger version

Name:	bcompare-diff.png
Views:	80
Size:	50.4 KB
ID:	81187
    No matter if I copy from left to right or v.v., it stays different.
    If I try "Compare content", binary: It still says different.
    If I compare by doubleclick, is says equal
    If I compare as hex it also says equal.
    Why does it show different in folder view?



  • #2
    Because the line endings on Linux and Windows are different (lf vs. cr+lf), and your copy does an automatic conversion. That's why your 12 line file is different by 12 bytes. I'm pretty sure there's a way to force a binary copy that would preserve the line ending during a Linux=>Windows copy and vice versa, but I'm not sure where it is.

    Comment


    • #3
      Then: How can I enforce beyond compare to always use binary copy mode? I don't want automatically conversion. Never. Regardless, if on existing or new comparison, regardless which protocol is used.
      I understand BeyondCompare as a comparison and synchronization tool, not as a modify-on-copy tool... It should behave like that.

      Comment


      • #4
        In Tools > Profiles You can change the default options.
        If You have changed "Transfer" settings for a specific profile, so that it does not use the default, You must change also for that profile.

        Regards

        Rodolfo Giovanninetti


        Click image for larger version

Name:	TransferType.PNG
Views:	23
Size:	11.5 KB
ID:	81197

        Comment


        • #5
          Rodolfo is correct, the default is Auto for FTP Profiles, but you can update the default to Binary. You can also double check any existing Profiles to make sure "Use Default" is enabled (to match <default>), or that they are also set to use Binary.
          Aaron P Scooter Software

          Comment


          • #6
            Thanks, it works for me with binary. :+1:

            Comment

            Working...
            X