Announcement

Collapse
No announcement yet.

Windows 64-bit installer doesn't automatically give UAC administrator prompt

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Windows 64-bit installer doesn't automatically give UAC administrator prompt

    On some of my Windows systems (both Windows 10 and Windows 7), the 64-bit installer doesn't automatically upgrade to Administrator, and the installation defaults to AppData\Local instead of C:\Program Files. If I enter a C:\Program Files directory, it fails because it's not in administrator mode and can't write to that directory. If I explicitly run the installer in administrator mode, that installs OK, but I do not get the File Explorer context menus.

    This happens on PCs where I have previously installed for "this user only" instead of "all users". I have since uninstalled the "this user only" copy, but I suspect it recorded that this is probably a "this user only" install and follows a different path that it would for a virgin install.

    Is there something that I need to clean up from my file system or registry to get the normal behavior of automatically uplifting to administrator mode and installing in C:\Program Files (and hopefully getting File Explorer context menus working again)?

  • #2
    Hello,

    For a Standard Windows User (which would require a different Windows Administrator login to allow), BC4's setup allows running in a limited mode so that these users can install the software without elevation.

    You are probably right about the "this user only" issue. If you need to install as a Standard User but to Program Files, do use the Right-click -> Run as Administrator, and you would want to install as for All Users. An uninstall, reboot, and reinstall might clear it up, but we also have a registry patch you can manually push out to help with the shell extension:
    http://www.scootersoftware.com/suppo...?zz=kb_shellex
    Aaron P Scooter Software

    Comment


    • #3
      you should click right mouse to the installer, and choose run as administrator

      Comment

      Working...
      X