Announcement

Collapse
No announcement yet.

File Timestamps not preserved when files are copied from symbolic links

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • File Timestamps not preserved when files are copied from symbolic links

    Hi,

    I want to copy files from a folder on a NTFS Volume that contains symbolic links to my real source files.
    My destination volume is an USB Drive formatted in FAT32 file system.

    I have selected "Session Settings - Handling - Follow Symbolic Links", so I see the source files as files.

    Then I select "Mirror Left" to mirror the files from the source folder to the destination USB drive.

    The copy operation works without problems, but the timestamps of the destination files are set to the current time an date, not to the time and date of the source files.

    When I use "Touch..." I can copy the timestamps from the source files to the destination files, but why isn't this already done during the copy process?

    Is this a possible bug, or have I done something wrong?

    Best regards,
    Jörg

  • #2
    Hello,

    Thanks for the report. If you try performing the same copy using Windows Explorer (same Source/NTFS, select file and Copy, then Paste into the same Destination/USB/Fat32), what behavior do you see?

    I've tried setting up a similar scenario on my test machine, but the copy of a symlink file (where the link has a newer timestamp than the target file) from NTFS to a Fat32USB, the destination copy of the file has the original file's Last Modified timestamp preserved.

    Are you using Windows 10 with all recent updates applied? If you copy to another C:\temp\ folder on the NTFS drive, is the timestamp preserved in this scenario?
    Aaron P Scooter Software

    Comment


    • #3
      @Aaron,

      thank you for your reply.

      In the meantime I cannot reproduce the problem.

      I assume it was a problem of the software I used to generate the Symbolic Links:
      (Link Shell Extension http://schinagl.priv.at/nt/hardlinks...kshellext.html).

      After a reboot of my machine the copy operation works fine again with Beyond Compare and with Windows Explorer.

      I assume that the link shell extension does some inteference with the file copy operations (maybe they use a "Copy Hook Handler").
      So when I generated the symbolic links, something might have gone wrong.

      Today I tried the same operation again for testing, as you asked me, but now everythings works fine.

      I am using Win 7 SP1 64 Bit.

      I will come back to this thread if the error shows up again.

      Thank you very much!

      Jörg

      Comment

      Working...
      X