Announcement

Collapse
No announcement yet.

Quick Select Encoding Issues

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Quick Select Encoding Issues

    Hi, UTF-8 BOM does not seem to be selectable on the quick select. I'll show you below.
    https://i.imgur.com/eyVLyMF.png
    This is the first image that shows UTF-8 BOM however when you click on it.
    It shows this.
    UTF-8
    https://i.imgur.com/2mLqAZg.png
    There is no way to switch views at all from UTF-8 to UTF- BOM AT ALL.

    The only other method to view in UTF-8 BOM is to convert the entire document with save file as or have an already encoded UTF-8 BOM document. Stated in this post below.
    https://www.scootersoftware.com/vbul...coding-request

    Here is a picture of File -> Save File As
    https://i.imgur.com/23h96yf.png

    There should be a UTF-8 BOM option on the quick select menu as I find it ridiculous that there is no other way to do it.

  • #2
    Exios also contacted us by email, here is the response I sent by email for anyone else following this thread:

    The choice when opening the file is the encoding, which is UTF-8.

    If a UTF-8 file has a BOM or not is a fact of the file, not a choice about how to read the file. After you select UTF-8 from the dropdown, Beyond Compare displays UTF-8 BOM to indicate the file starts with a BOM or UTF-8 to indicate the file does not start with a BOM.

    If you want to add or remove a BOM from a UTF-8 file, then you should use File > Save As.
    Chris K Scooter Software

    Comment

    Working...
    X