Announcement

Collapse
No announcement yet.

New MTP Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New MTP Issue

    I have been using BC4 to sync my ebooks and documents with my Amazon Kindle for about 6 months. There were some initial problems with drivers that I worked out, but just recently I am unable to access the MicroSD storage card on the device with BC4. I can access it in Windows and I can access the Internal storage, but the External storage gives an OLE error 80042009. Google has been of little help with this message.

    I updated Windows, tried a variety of different drivers, cables, and even a different computer. All results are the same: Kindle recognized, Internal storage accessible, Micro SD External storage = No Such Luck.

    Ideas?
    Weird Kindle MTP issue: Internal vs external storage access.

  • #2
    Hello,

    Thanks for the report. Which make/model Kindle are you using? And could you provide more details on the initial workaround you used to create the connection to transfer the files?
    Aaron P Scooter Software

    Comment


    • #3
      I am using an Amazon Kindle Fire HD 8 (7th Generation) running Win10 Pro x64 Build 1809 with all patches/updates applied. When I first connected it, the Kindle displayed as an Unrecognized Device. I did a manual driver install, selecting not the Acer, nor the Microsoft MTP driver, but the generic one that comes standard with Win10 (Yes it's Microsoft, but not the one that displays MS as the developer. THAT one gives the error "A service installation section in this INF is invalid." The driver I am using is dated 6/21/06, version 10.0.17763.1).

      Once that driver was installed, Windows recognized the device, recognized it as an Amazon Fire, and I was/am able to browse the file structure, create, read, update, delete, etc... The parameter I was using to access it with BC4 was the address: mtp://Fire/Storage device/Android/data/com.amazon.kindle/files/..... etc. As I stated, this was working perfectly until just a little while ago. I am still able to access the Kindle in Windows Explorer and other File Management applications (XYplorer) and perform CRUD actions. I can even browse the directory tree within BC4, but when I set a directory as the base folder, it gives me the error in the picture I attached: "Error opening folder", "Unable to load mtp://Fire/Storage device: OLE error 80042009" in the logging pane, and a popup window: "Folder Not Available".

      Until I find a resolution to this, I have been removing the MicroSD card and inserting it into a USB flash card reader and using BC4 to maintain my files that way, which works flawlessly (did I mention how critical your software is to my computer sanity? You guys are awesome. ). The fact that I can browse the card inside the Kindle from other apps along with the fact that I can manage it using BC4 outside the Kindle leads me to suspect a problem in the implementation of the MTP protocol communication between Kindle and BC4 as it relates to non-integrated (non-primary?) storage devices, but I absolutely defer to your analysis.

      Comment


      • #4
        We've ordered an Amazon Kindle Fire HD 8. We'll update this thread after we've tested it.
        Chris K Scooter Software

        Comment


        • #5
          I should have updated this earlier, but I got it working. I shut the Kindle down (I had done this before with no success) and removed and reinserted the MicroSD card. When I rebooted, I was able to successfully access it through Beyond Compare. As I said in my previous post, I was able to access it through many other venues jut not through Beyond Compare, so the idea of restarting the Kindle and reseating the card didn't initially occur to me. I hope this issue doesn't reoccur, but if it does, I will keep you updated as to anything that I can correlate it to and maybe find out why it's happening.

          Thank you again for awesome software and service!

          Comment

          Working...
          X