No announcement yet.

Very slow folder compare USB<>Internal HDD

  • Filter
  • Time
  • Show
Clear All
new posts

  • Very slow folder compare USB<>Internal HDD

    FWIW ...

    When comparing a folder on external USB HDD with a folder on internal HDD, Beyond Compare is very slow.
    It takes 5-6-7 minutes.
    When done, the buttons in the toolbar don't respond: nothing happens when changing, e.g. Folder structure to Files only.
    Or clicking on [* All] or [#Diffs].

    Clicking on [Refresh] results in a crash.
    This is also the case with the latest (15 jan) build.

    Reproduced this a few times.
    Reported by sending a crash report.

    Hope it'll be fixed.

  • #2

    We'll take a look at the stack trace you emailed in. If you wanted to manually save the crash report and email it to along with a link to this forum thread, I could link all of the references together.

    Switching Folder View modes (from a structured mode to Ignore Folder Structure, or back) is a very intensive task and may cause that tab to become unresponsive while processing. If you try any of the other commands first, are they all equally unresponsive, or is it this specific task that is causing the freeze and crash? I would suggest testing in one of the other 3 view modes (Always Show Folders, Compare Files and Folder Structure, Only Compare Files) first, to narrow down if it is the intensity of the Ignore Folder Structure mode that is causing the problem.
    Aaron P Scooter Software


    • #3
      Hello to you, thanks for feedback. I have sent a crash report twice. So your developers should have it.
      As for the folder \ sub folders involved, please note: it concerned 1 root folder, with 3 sub folders containing a total of 93 sub sub folders with 464 files both left and right.

      I gave it a try again. After the compare (about 6 minutes), I clicked on the [Refresh] button and BC crashed.

      I copied the folder from external USB -> internal HDD and did the compare.
      Same problem.
      After compare: refresh.

      Sent a report.

      Let's see.

      I tried again, whilst using the folder on internal HDD

      Important (suggest to inform developers accordingly)

      This time, after compare finished I did -not- click on the [Refresh] button.

      Instead I used the other buttons, like [Structure] and [#Diffs].
      I selected [Flatten] and [*All}
      The results were displayed immediately.
      Remember, whilst comparing the same folder on external USB drive <> Internal HDD clicking on these folders, nothing happened.

      So far so good,.

      In this mode [Flatten] + [*All] doing a refresh does -not- result in a crash.
      Changed in to Structure mode and refresh caused a crash.
      So it is limited to that mode only I guess.

      Last edited by bcdewul; 17-Jan-2019, 11:04 PM.


      • #4

        Looking through the crash report, there's some information but not enough to know exactly what is happening. One hunch: which columns are visible and which is currently sorting? If you click on the Name column a couple times to verify it is sorting on Name, then reload the session, does this help (sorting on name as loading/loaded)?
        Aaron P Scooter Software


        • #5
          Sorry for the delay.
          Regretfully the screenshots I made and passed on together with the crashreport, they were too small to see what they were about. Column headers were just [...]

          However, as said, I copied the files from the USB drive onto an internal HDD and did the same thing, using folders on internal HDD.

          Now coincidentally -that- compare still existed (the source and destination folders/files as well as the profile. So I ran it again.

          Now I see what probably caused the issue, columns are:

          CRC . . .
          I didn't pay attention to the columns.

          Removed the CRC - Refresh caused an error again, reported it and made reference to this thread.

          I stop here.
          It is just an exceptional case: normally users, after having done a folder compare, won't click on the Refresh button
          That aside, having the CRC column active in this scenario is a bit unusual as well.

          Thanks anyway.


          • #6

            And if you click on the Name column twice (even after removing CRC) does that help?
            Aaron P Scooter Software


            • #7
              As said, probably it is limited to Refresh button only.
              Using other buttons went fine.


              • #8
                Sorry, what I mean is, when using Refresh triggers the issue, but if you remove CRC and Sort by Name (click Name specifically a couple times), then close BC4 and re-open BC4 and launch that session (now sorting on Name by default on load with no CRCs), does Refresh still trigger the issue for you?
                Aaron P Scooter Software