Announcement

Collapse
No announcement yet.

BC4, BC3: Unicode symbol is not displayed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BC4, BC3: Unicode symbol is not displayed

    I tried to use BC for comparing two textual little-endian UTF16 files with symbol "⚫" (U+26AB). Instead of the symbol I see box with question. Why and how to fix it? Notepad shows symbol correctly.

    For file and screen see attachments.
    Attached Files

  • #2
    Hello,

    Which Font are you currently using? On my own test system this character is showing up as expected.

    If you go to the Tools menu -> Options, Colors/Fonts tab, in the File views, which font is set for Editor Font? If you change this to other fonts, does it help?

    Update: I tested this on BC3 and BC4 with default fonts. The above directions are for troubleshooting with BC4's settings/menus.
    Last edited by Aaron; 19-Oct-2018, 01:39 PM. Reason: Update
    Aaron P Scooter Software

    Comment


    • #3
      It is Consolas font. The Notepad uses the same and display symbol correctly. Hence I think problem does not relate to font.

      Comment


      • #4
        What version of Windows are you using?
        What are your Windows regional settings?

        The character displayed correctly in Beyond Compare 4.2.8 on Windows 10 Pro with US English regional settings. Behavior might be different on a different version of Windows or with different region/system locale settings.
        Chris K Scooter Software

        Comment


        • #5
          Now it works in BC3 and BC4. I installed additional font to the system and setup up it as Editor Font. But I don't understand why Notepad displayed and displays symbol correctly with font settings - Courier New.

          Win 10, system locale - United States.

          Comment


          • #6
            Sorry, I don't know why it isn't displaying correctly on your PC. On my Windows 10 PC with system locale - United States, it displays correctly.
            Chris K Scooter Software

            Comment

            Working...
            X