Announcement

Collapse
No announcement yet.

Folder compare STILL not working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Folder compare STILL not working

    I'm trying to compare two folders with xml files in it.

    I've created a sesssion, loaded both folders.

    I have the following settings in the Comparison tab of Session Settings:
    Compare contents Rules-based comparison
    Override quick test results = Checked

    In view, ignore unimportant is checked and highlighted.

    I've tried pushing Minor (with squiggle) button

    I've tried to do it with the following script:
    # SCRIPT **************

    # Load the base folders. Right now local and VM. Eventually both VM.
    # W: is the shared folder path on the VM as BC doesn't except
    load ".\2102" ".\2104"

    #This line says to use the rules we set up in BC UI and ignore the fields we deemed unimportant(The boxes we unchecked in the UI).
    criteria rules-based ignore-unimportant

    #expand all

    select newer.files older.files diff.files

    # Report
    folder-report layout:xml options:display-all,include-file-links &
    output-to:"compare.xml"


    #folder-report layout:side-by-side &
    # options:display-mismatches,include-file-links &
    # output-to:".\RXCompareReport_%DATE%.html" output-options:html-color



    Using this batch script

    @echo off
    echo ***** COMPARING FILES *****
    set scriptPath=".\RXCompareHtmlIgnore.txt"
    set hostPath=".\2102"
    set guestPath=".\2104"
    set reportPath=".\My Report.html"
    REM Keep spaces in front of file paths and carets at the ends. Also, there can be no spaces after carets.
    BComp.exe @%scriptPath% %hostPath% %guestPath% %reportPath% //start "" "My Report.html"

    No matter what I do, the Rules do not apply and it doesn't ignore the unimportant differences.

    I just don't get it, this is base functionality. Why is this so difficult?

    There's nothing for the program to get "confused" about, they're all xml with the same file names!

    The only time I can get it to ignore-unimportant is if I go into one xml, uncheck all the boxes that I've setup as unimportant...
    Then it works for that ONE file only.

    Please, help me out here, I've spent WAY too long trying to do what should be simple.

    Thanks,
    R

  • #2
    Hello,

    It sounds like in the graphical interface, when you first double click the file, it shows as Important and not Unimportant. This would be because the Grammar Elements are defined, but not their status (Important/Unimportant). You need to also define the element as Unimportant by Default, so that when you double click, there is no unchecking needed. This then cascades into rules-based criteria, report generation, and scripting.

    We have an article and video walkthrough here:
    http://www.scootersoftware.com/suppo..._unimportantv3

    Or, when you double click on your files and uncheck your defined elements, before you click Ok, update the bottom dropdown from "Use only for this view" to "Also update session defaults"

    This updates the defaults. Then close the program and relaunch BC4, and reopen your files. They should be unimportant right away, without modification.
    Aaron P Scooter Software

    Comment

    Working...
    X