Announcement

Collapse
No announcement yet.

Grammar setting not sticking.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grammar setting not sticking.

    Thanks for getting me past the conversion obstacle.

    I have another issue. When I make the Grammar setting to be a string of 1 to 71 columns to compare, this setting
    gets applied to my other compares by default. I have another compare on the same file type for 1 to 133 columns in text compare. When I change 1, the other Grammar setting gets changed too. I put the compares in separate folders
    but that does not make a difference. I tried doing both a save as View only and Session only and neither makes a difference.

    I would like the Grammar to be unique for each folder. I also tried clicking the Lock button to see if the Grammar
    setting would be locked but this is not kept.

    Thanks.

  • #2
    issue overcome. orphan line question...

    I got past the 'non stick' issue. I created a new item and made this item 1 for column 1 through 133. So I have Item 1 and Item 2. I checked off item 2 for the COBOL compares. Then locked each session. I checked off Item 1 for reports (length 133). Then locked these sessions. I got the Grammar to be unique for the same file type (*.*) or blank. Are lines that are in File 1 but not File 2 always unimportant ? I ask because the color for unimportant shows up on these lines. I think this is orphan line. I saw there is a check box to make orphan lines important. I assume an orphan line is a line in File 1 that is not in File 2. The entire line in File 1 is coming in as unimportant. Thanks.



    Originally posted by mikedgre View Post
    Thanks for getting me past the conversion obstacle.

    I have another issue. When I make the Grammar setting to be a string of 1 to 71 columns to compare, this setting
    gets applied to my other compares by default. I have another compare on the same file type for 1 to 133 columns in text compare. When I change 1, the other Grammar setting gets changed too. I put the compares in separate folders
    but that does not make a difference. I tried doing both a save as View only and Session only and neither makes a difference.

    I would like the Grammar to be unique for each folder. I also tried clicking the Lock button to see if the Grammar
    setting would be locked but this is not kept.

    Thanks.

    Comment


    • #3
      If you click into the Unimportant text, what grammar element shows in the bottom status bar of each pane? This grammar is likely marked as unimportant; otherwise, orphan lines are different and would usually be Important.

      If you are still having trouble, could you post screenshots, or email into support@scootersoftware.com with a link back to this forum thread, screenshots, and if you can: your sample files and BCSupport.zip from the Help menu -> Support, Export. This way, we can recreate your current comparison and see what is going on.
      Aaron P Scooter Software

      Comment

      Working...
      X