No announcement yet.

Synchronisation within archives loading endlessly

  • Filter
  • Time
  • Show
Clear All
new posts

  • Synchronisation within archives loading endlessly

    Dear all,

    I have a problem which occurs when I synchronise within archives. I use Beyond Compare 4 (64 Bit, Ver 4.2.3 Build 22587, German version, today's date is 15.12.2017).

    My setting is: I synchronise a set of folders between my home laptop and my USB stick. Then I synchronise my USB stick with a second computer at my work (i.e. three parties: laptop at home <> USB stick <> computer at work). Within these folders there are a lot of archives, mostly zip.

    At home, when I synchronise , I have enabled the option "synchronise within archives". This works very fine, differences between zip-archives are pointed out correctly and I can transfer single files within zip-archives. At work I use the same synchronising options. But when I keep "synchronise within archives" switched on, then Beyond compare would load endlessly (the "stop" symbol on top is blinking yellow/red and nothing else is happening for hours). There is no error message, BC would just not come to an end. Finally I have to force BC to be shut down. However, when I deactivate the option to synchronise between archives, everything is fine and working fast.

    How can this be? Both my home computer and my computer at work use Kaspersky antivirus software. My computer at work, however, uses a network profile (my data is not stored locally on c: but on a network drive). Still, I do not understand why Beyond compare does not like my settings at work. What could cause this problem?

    Thank you very much!
    Last edited by Yukusoona; 15-Dec-2017, 03:01 PM.

  • #2

    Instead of syncing, if you issue Session menu -> Session Settings, Handling tab, and Treat Archives as Folders Always, then an Edit menu -> Expand All, is there a specific archive that is having trouble expanding?

    The cancel button would send the abort command, but may need to wait until it is done with the currently expanding/scanning archive(s).

    If you let this action sit for an extended period, does it continue to the next archives or finish?
    Aaron P Scooter Software


    • #3
      Hallo Aaron,

      I am afraid I cannot tell because BC gets stuck in loading (without end, so the abort command would not work and I have to force closing by Alt+Ctrl+Del). So I cannot really say if there is one specific archive that causes the trouble. However, when I sync at home (where I do not experience any problems, and as I said before the files are exactly the same) BC would give me some red warning notifications in the bottom window, telling me that some specific files (*.flv and *.swf) are not valid archives (in German: "Laden von C:\xxx\xxx\x.flv nicht möglich: Kein gültiges Flv archive"). So I wonder if these files might cause the trouble?

      Maybe I could try the following: Keep the option "Treat Archives as Folders Always" but exclude *.flv and *.swf files from being treated as archives? Is that possible? I would want BC to compare *.flv and *.swf files like any other file but not expand and look inside them.

      Thank you!


      • #4
        I am now at work and have tried to synchronize again. Here some more specific information on the problem:

        BC is again loading endlessly and seems to have got stuck in this process ("stop button on top blinking"). In the small window on the bottom there are several error messages, such as:
        Loding of K:\xxx\xxx\xxx\ not possible: File K:\xxx\xxx\xxx\ not found - Native error: 00012
        Loding of K:\xxx\xxx\xxx\xxx.flv not possible: not a valid flv archive

        While BC keeps on loading I at least can handle the files that have been compared up to that time. When I take one of the zip files, for instant, BC tells me that there is a problem with that file on my computer at work (file is marked with a little red box with black cross in it) while the file on my USB stick is correct. When I pick this one data and ask BC to open for synchronization or folder compare in a separate window, then BC cannot open the folder on the left side (= computer at work) and pops up a window with the messagse: folder not available (in German: "Ordner nicht verfübar"). On the right side (= USB stick) the folder opens correctly.

        I am not sure why BC does not like these files on my computer at work. The only real difference to my USB stick and my home computer ist that at work my files are not stored on a local hard drive (c:\) but come via intranet (k:\).

        I hope these information help to find the source of my problem?


        • #5

          As a quick test, you can remove the archive association for those types in the Tools menu -> Options dialog, Archive Types tab:
          Fly archive and Shockwave Flash. Remove the extensions and then fully close and restart BC4.

          If either of these is corrupt, or has the extension but is in a format we don't expect, it could be causing this kind of error. For the difference between computers, do you ever sync the full file? Are they binary equal archives? Or are the trouble swf or flv different versions of the same file, which could have different behavior when attempting to unpack them. Unpacking over a network location may need to download a temporary version, and both sync steps are copying From these drives to the same Destination USB stick, correct? Or is either test copying From the USB stick? A difference in direction could also explain a difference in behavior, if that same test is not repeated on the other system.
          Aaron P Scooter Software


          • #6
            I did the quick test and removed the archives flv and swf (anyway, I mostly need zip-compare). This did not work, unfortunately.

            I use my USB stick to keep a set of files and folders the same on my home and my at-work computer. So at home I sync my data with my USB stick (so USB stick contains latest version of all). At work I sync USB stick to at-work computer. After my work has been done I sync back to USB stick etc. And before I start working at home I sync back from USB to my home computer. So, generally these are the steps I do every day:

            Home => USB => Work => USB => Home => USB (...)

            Again, at home everything is fine. After I have removed swf and flv, no errors at all are reported at home, although I use the option "treat archives as folders always". Everything is perfectly fine. At work I use exactly the same version of Beyond Compare (USB stick installation), i.e. without flv and swf. Still, Beyond Compare tells me, that certain zip archived could not be found (for error code see my last post) and gets stuck in loading, never ending.

            Maybe it has something to do with the network location of my data at work. As a workaround I have decided to do as follows:
            At work I have switched off the option "treat archives as folders always". Then everything is working perfectely fine again (just like at home). The only difference for me is that Beyond Compare tells me that all my zip files are not identical (although they are when you look into them). What I do then is, I open the zip files separately in "folder-compare-mode" and then I open them one after another to see if there are any differences in their contents. If there are not, Beyond Compare uncolours them from red (difference) to black (no difference) and I am happy again... So, Beyond Compare can obviously handle those zip files without any problem (it can technically open them and compare them). It is the sync mode that causes problems in my case. What a pity.


            • #7

              To confirm, you rebooted the BC4 app after altering the archive extensions? Altering the extensions requires a restart to apply. Altering these two archive types would not change the behavior for .zips or other archives; only those two extensions.

              You mention that everything works from the Home location, but does this mean that the Work location has a corruption or file that never transfers to the USB? Therefore any attempts to replace it would hit the error, since treating as folders and failing to expand would be an error.

              For the problem zip, if you run a Test from an archive problem, such as WinRAR, does it succeed the test? Able to fully extract to a temp directory?
              Aaron P Scooter Software


              • #8

                Yes, I restarted BC after altering the extensions. What I meant is that altering the extensions did not solve my problem, so it is not the flv and swv archives that cause the problem, obviously.

                It really seems to be a matter of the sync mode as far as I can see. What I did and what maybe helps to give a clue:

                With the help of another programme (TotalCommander) I made all three parties involved identical (i.e. home computer, at-work computer and USB stick). So, I copied all zip archives overwriting the alternative versions, making them really identical in all three places (before that I used to open the archives and to copy newer contents to the other archives, so that they contained the same files but were not identical in comparing them as a file). The situation I now have is that there are really no differences between my home computer and the USB stick and there are no differences between my USB stick and my at-work computer.

                When I compare the at-work computer with my USB stick in "folder compare mode", Beyond Compare shows no differences and works perfectly fine! (as it has used to do before) I can also open all archives (in my case zip files only) and Beyond Compare can compare the contents, presenting them as identical. So summing up, Beyond Compare has no problem in reading all files in my at-work computer, including all archives, and the files do not seem to be defective in any way.

                But now: as soon as I change to sync-mode, comparing my at-home computer with my USB stick (where "folder compare mode" did not show any problems), Beyond Compare tells my that certain zip files cannot be opend (error message: Loding of K:\xxx\xxx\xxx\ not possible: File K:\xxx\xxx\xxx\ not found - Native error: 00012). Beyond compare gets stuck in loading and loading and loading... until I interrupt by Ctrl-Alt-Del. So, here I am and I have no idea where the problem lies. Does sync-mode read the files in a different way than folder compare mode?

                What I still could try (but it would take a lot of time because of the vast amount of folders and files), is to go step by step through all folders and apply sync mode to each one individually. Then I could find out if it is a specific folder that causes the trouble in sync mode.


                • #9

                  There is not difference between Folder Compare and Sync in how the archives could be handled, but it depends on your Session menu -> Session Settings if there's a configured difference. The Sync would auto-expand the archives if archives are Always As Folders, while the Compare session type can be configured to auto-expand or not; you can issue a manual Expand All command (or double click the specific error file mentioned above) to see if expanding it in the Compare session throws the same error.

                  With the above example, does this one example trigger the error each time? The subfolder there could be your test if that file reproduces the problem. I would also actually remove the USB stick for now from the testing, too: load only one local folder one one side, and blank on the other. Do either of these cause the error while expanding?
                  Then load a new folder compare with blank on one side and the USB on the other, and repeat the expansion test.
                  Aaron P Scooter Software


                  • #10
                    I guess, I have found the solution.
                    There have been some defective files in one folder, their name beginning with a "." and only a few kilobytes of size. Some of these files hat the ending "zip" but they were no intact zip files. I deleted the folder and now the problem is gone. For some reasons I do not know, the whole folder was excluded from my sync settings at my home computer which is why the problem never occured at home. However, these obviously defective files were never reported by Beyond Compare as the trouble-causers (they never appeard in the list on the bottom) but instead Beyond Compare used to crash instead. So I have never had the chance to excluede them from my sync session from the start. I am sorry for troubeling you in this forum.

                    Best regards!


                    • #11
                      Thanks for the follow-up. The crash must have happened before the log could report the error (and the error text turned out to be a red herring). In the future, a good test to try and find this type of difference in behavior is the test where instead of loading both sides of the compare, we load only one (just Left or just Right) and Expand All. This would help limit the test scenario to just the Work computer (independent of USB). Another good test would be to compare the Session Settings (XML export) to find the difference in Filters.
                      Aaron P Scooter Software