Announcement

Collapse
No announcement yet.

Uninstall fails

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Uninstall fails

    BC 4.2.2.22384
    Windows 2012 R2
    Admin user

    I tried reinstalling and then uninstalling, but it still fails with this error.

    Windows Application Log, Event 1000

    Faulting application name: _iu14D2N.tmp, version: 51.1052.0.0, time stamp: 0x591dd6c2
    Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
    Exception code: 0xc0000005
    Fault offset: 0x0018fad0
    Faulting process id: 0x100c
    Faulting application start time: 0x01d3008fd6230e66
    Faulting application path: C:\Users\ADMINI~1\AppData\Local\Temp\_iu14D2N.tmp
    Faulting module path: unknown
    Report Id: 15058c27-6c83-11e7-80cc-0050569b1bbe
    Faulting package full name:
    Faulting package-relative application ID:

  • #2
    Hello,

    The most likely cause is running with insufficient privileges. Being an Admin account does not mean every task is elevated. Is there a UAC prompt when attempting to Uninstall and do you accept it?
    https://technet.microsoft.com/en-us/...or=-2147217396

    If you right click and run the uninstaller with the Run As Administrator option, does this help?
    Aaron P Scooter Software

    Comment


    • #3
      Thanks, Aaron.

      I get no UAC prompt.

      This is the uninstaller I'm running - C:\Program Files\Beyond Compare 4\unins000.exe
      When I use the Run As Administrator option, it fails with the same error.

      Comment


      • #4
        Hello,

        What if you navigate to the Add/Remove Programs section of the Control Panel?

        Are you directly accessing the physical machine, or are you running through Remote Desktop or something like Citrix?
        Aaron P Scooter Software

        Comment


        • #5
          Trying to uninstall from Add/Remove Programs throws the same error.

          I am accessing the server via RDP.

          Comment


          • #6
            Hello,

            Have you rebooted the system since hitting the error? After a fresh restart can you then run the uninstaller from Control Panel -> Add/Remove?

            Did you try the troubleshooting steps available in the Microsoft KB article above? There's a set of steps for each possible cause.
            Aaron P Scooter Software

            Comment


            • #7
              I will reboot the server tonight and try again tomorrow.

              That MSKB article is about System Performance Counters, not application errors.

              Comment


              • #8
                No joy. After a reboot, uninstalling fails with the same error, both from the control panel and when running unins000.exe as administrator.

                Is there a guide to manually remove the application from the file system and registry?

                Comment


                • #9
                  The file system is your install directory (default: Program Files\Beyond Compare 4\), and your uesr's AppData settings directory (%AppData%\Scooter Software\Beyond Compare 4\), and the registry under Current_User\Software\Scooter Software\Beyond Compare 4\.
                  Aaron P Scooter Software

                  Comment

                  Working...
                  X