Announcement

Collapse
No announcement yet.

How Do I ignore numberical differences with the same absolute value

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • JPike
    replied
    Thanks, I figured as much, but wanted to confirm. I appreciate your feedback and help though.

    Leave a comment:


  • Aaron
    replied
    Hello,

    For a delimited file, the Table Compare is the best at parsing and aligning the data. For this view, changing the value in the base file (or a cloned copy of the file) would be best.

    The Text Compare would allow comparing the text of the file, but has no numeric tolerance for unimportance. Text Compare uses Regular Expression definitions, mostly.
    The Hex Compare is more for binary files, and doesn't have any type of unimportance you are looking for.

    Leave a comment:


  • JPike
    replied
    Originally posted by Aaron View Post
    Hello,

    Our Table Compare currently only supports a hardcoded value of the '-' after the $. ie: $-123,456.78
    We're working on enhancing and expanding the Table Compare to better handle this scenario. Likely, we would follow the Windows Regional Settings. Default setting uses '()' for negative currency. ie: ($123)
    Aaron,
    Thanks for the reply. Might there be another way around this? Text Compare does not seem to allow for the individual field attributes, so that does not seem like a work around. Would Hex Compare have any value, or, is my best bet an attempt to change the sign in the base file?

    Leave a comment:


  • Aaron
    replied
    Hello,

    Our Table Compare currently only supports a hardcoded value of the '-' after the $. ie: $-123,456.78
    We're working on enhancing and expanding the Table Compare to better handle this scenario. Likely, we would follow the Windows Regional Settings. Default setting uses '()' for negative currency. ie: ($123)

    Leave a comment:


  • How Do I ignore numberical differences with the same absolute value

    I am attempting to do a Table Compare, but have a large number of differences that I cannot seem to filter out. Both files are csv. An example line would be (left file) Transaction - Withdrawal, Amount -$123,456.78. (right file) Transaction - Withdrawal, Amount $123,456.78. The only difference is the absence of the sign. Table Compare seems to allow me to pick how each field is treated. In the session settings dialog, I removed the default and set the type to numeric with a tolerance of 0.00 and absolute. Yet, somehow all of the differences are still displayed.

    Any help in educating me on how to get rid of these would be greatly appreciated.
Working...
X