Announcement

Collapse
No announcement yet.

21095 Amazon S3 failure

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 21095 Amazon S3 failure

    1 Can someone confirm that Beyond Compare 4 access to Amazon S3 works for them?

    2 In Folder Compare, whenever I click [+] to expand an Amazon S3 profile e.g. http://i.imgur.com/JMrsqIu.png , BC changes the displayed name and fails with this error: http://i.imgur.com/TuqxySM.png . Any ideas?

    3 In Folder Compare, wherever I attempt to open an Amazon S3 profile, BC fails with this error: http://i.imgur.com/e1VlALR.png . Any ideas?

    4 This Help topic http://i.imgur.com/2fa0CpN.png is missing Amazon S3 profile.

    2 & 3 happen regardless of whether Access key ID and Secret access key are filled or blank.
    Last edited by chrisjj; 18-Aug-2016, 04:59 PM.

  • #2
    1. Yes, I use it regularly. 2. Not for me. When I click + to expand, it thinks for a few seconds and then shows my buckets. Of course, my Access and Secret keys have the correct values to make this happen. I would not expect it to expand if they were blank.

    Comment


    • #3
      Hello,

      Yes, Amazon S3 is currently working. If 2 and 3 happen regardless of the key id and access key, I suspect you have a typo or paste error (extra space).
      Aaron P Scooter Software

      Comment


      • #4
        Originally posted by tfrost View Post
        1. Yes, I use it regularly. 2. Not for me. When I click + to expand, it thinks for a few seconds and then shows my buckets.
        Thanks.

        Originally posted by tfrost View Post
        Of course, my Access and Secret keys have the correct values to make this happen. I would not expect it to expand if they were blank.
        I would not expect it to give an error if they were blank. Particularly one that doesn't mention the Access and Secret keys.

        It does.
        Last edited by chrisjj; 19-Aug-2016, 02:45 PM.

        Comment


        • #5
          Originally posted by Aaron View Post
          Yes, Amazon S3 is currently working. If 2 and 3 happen regardless of the key id and access key, I suspect you have a typo or paste error (extra space).
          Thanks. ID and key are copy and pasted from the Amazon CSV, with no error. I suspect some permissions issues at Amazon and will check.

          Comment


          • #6
            Well, no permissions issues found at Amazon so I am still stumped.

            I have tried the same ID and key in client s3Browser and they work fine. Copy and pasting the Id and key from that program or the Amazon download CSV into BC4 gives me the error on every [+] click



            Comment


            • #7
              Select the root node without expanding it and click "Ok" in the browse dialog. It should try to load that into the folder compare, and the log panel should have a more useful error message.
              ZoŽ P Scooter Software

              Comment


              • #8
                Originally posted by ZoŽ View Post
                Select the root node without expanding it and click "Ok" in the browse dialog.
                I really hope you're not saying selecting the profile in the left pane http://i.imgur.com/cwWh300.png is insufficient.

                [QUOTE=ZoŽ;52872]It should try to load that into the folder compare, and the log panel should have a more useful error message./QUOTE]

                I did it, and got this:

                Comment


                • #9
                  Try updating to the latest release of BC4. We may have some fixes present depending on which or where your Amazon buckets are located.

                  If you can also email us (including a link to this forum thread) with any bucket configuration information, we can try to determine which might be causing issues.
                  Aaron P Scooter Software

                  Comment


                  • #10
                    Expected behavior and troubleshooting steps do not always correlate. Obviously the expand button should work given a valid server, but testing a direct load is useful information when it doesn't.
                    Aaron P Scooter Software

                    Comment


                    • #11
                      Originally posted by Aaron View Post
                      Expected behavior and troubleshooting steps do not always correlate. Obviously the expand button should work given a valid server, but testing a direct load is useful information when it doesn't.
                      Surely the root node AND the profile in the left pane should both give a direct load.

                      Comment


                      • #12
                        Originally posted by Aaron View Post
                        Try updating to the latest release of BC4.
                        Done, to 21529. Same fail http://i.imgur.com/rq7qS97.png

                        Originally posted by Aaron View Post
                        We may have some fixes present depending on which or where your Amazon buckets are located.
                        Now you're scaring me.

                        My Q1, V2: 1 Can someone confirm that Beyond Compare 4 access to Amazon S3 region eu-west-1 works for them?

                        Comment


                        • #13
                          Hello,

                          Our S3 Ireland bucket is working correctly with our test account.
                          Region Name :EU (Ireland)
                          Region: eu-west-1
                          Aaron P Scooter Software

                          Comment


                          • #14
                            If it's failing outright, it hasn't gotten to individual buckets yet. BC will fail like that if you don't have access to list all of the buckets for that account. Try accessing the bucket by entering the path, including the bucket, directly, like :

                            profile:New Amazon S3 Profile (2)?BucketName

                            Now you're scaring me.
                            Amazon has a new authentication method that requires knowing which regions buckets are in, which wasn't necessary for the method we used until 4.1, and we've had to work out a few kinks with it. 4.1.7 specifically fixed an issue with eu-west-1 buckets that were created prior to 2013; newer buckets already worked. If you had encountered it, you would have gotten a different error message.

                            My Q1, V2: 1 Can someone confirm that Beyond Compare 4 access to Amazon S3 region eu-west-1 works for them?
                            Yes, we have an eu-west-1 bucket here that works fine. The issue is more than likely with your top-level user permissions. Specifically, we need the "s3:ListAllMyBuckets" permission set to "Allow". Does S3 Explorer allow you to see all of the buckets, or do you need to enter a specific bucket before connecting? We are planning on adding a "Default bucket" setting to the Profile to work around the "ListAllMyBuckets" requirement but haven't gotten to it yet. Adding the bucket name to the profile string as above is the current workaround.
                            ZoŽ P Scooter Software

                            Comment


                            • #15
                              Originally posted by ZoŽ View Post
                              Try accessing the bucket by entering the path, including the bucket, directly, like :

                              profile:New Amazon S3 Profile (2)?BucketName
                              It gives this http://i.imgur.com/jKBSHFH.png (I press Enter) then fails:



                              Originally posted by ZoŽ View Post
                              Amazon has a new authentication method that requires knowing which regions buckets are in, which wasn't necessary for the method we used until 4.1, and we've had to work out a few kinks with it. 4.1.7 specifically fixed an issue with eu-west-1 buckets that were created prior to 2013; newer buckets already worked. If you had encountered it, you would have gotten a different error message.

                              Yes, we have an eu-west-1 bucket here that works fine. The issue is more than likely with your top-level user permissions.
                              My top-level user permissions are at the Amazon defaults and cause no visible problems at all with S3browser.

                              Originally posted by ZoŽ View Post
                              Specifically, we need the "s3:ListAllMyBuckets" permission set to "Allow".
                              Worth mentioning that essential fact in the (currently non-existent) Help topic, I think.

                              Originally posted by ZoŽ View Post
                              Does S3 Explorer allow you to see all of the buckets
                              Yes. No problems at all.
                              Last edited by chrisjj; 22-Aug-2016, 01:38 PM.

                              Comment

                              Working...
                              X