Announcement

Collapse
No announcement yet.

BC4 Mapped Drives Missing from Browse for Folder Dialogs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • BC4 Mapped Drives Missing from Browse for Folder Dialogs

    When i browse for a folder in a saved session (or any other time for that matter), my mapped network drives do not appear in the list under "This PC" - only the local drives show up. This was never a problem in BC3 (which still works). I've had to keep BC3 installed in parallel in order to continue to do my work. I'm using Windows 10 Pro.

  • #2
    If You choose run as administrator, I believe that this is normal, since You are seen as a somewhat different user.


    Regards

    Rodolfo Giovanninetti

    Comment


    • #3
      Hello,

      Which Browse dialog are you currently using? BC4 supports two: Browse Using Profile and Browse Filesystem.

      Browse Using Profile should show all items, including network drives and MTP devices.
      Browse Filesystem will only show local file system locations, and excludes anything on the network.

      The Browse button has a dropdown arrow next to it which lets you pick either option.
      Aaron P Scooter Software

      Comment


      • #4
        I'm on the home screen, editing a saved session running as Administrator. I've tried both "Browse File System..." and "Browse Using Profile.." and neither show my mapped drives. BC3 does show them properly.

        Comment


        • #5
          Well, I did the obvious and completely uninstalled it including all settings and re-installed using Run As Administrator and everything is working as it should now. Thanks for your replies.

          Comment


          • #6
            If you are running as different Windows Users, it might help to use a Portable Install (all users share the same settings). However, I am unsure why BC3 and BC4 would show different behavior, or why the network devices would not be viewable in BC4 if they are viewable in Explorer.
            Aaron P Scooter Software

            Comment


            • #7
              This is due to User Account Control (UAC). UAC doesn't allow drives mapped in standard user context to be seen by processes running as administrator, and vice versa.

              Possible workarounds:

              1. Map the drives a second time as administrator. To map drives as administrator, open a command prompt with Run As Administrator, then issue the NET USE command.

              2. Set EnableLinkedConnections in the registry to bypass the UAC limitation. This allows drive letters mapped in standard user context to be accessed by processes running as administrator.

              Open regedit.
              Go to: "HKLM\software\microsoft\windows\currentversion\po licies\system".
              Create a new dword "EnableLinkedConnections=1".

              3. Access the network shares using UNC paths (\\server\share\folder).
              Chris K Scooter Software

              Comment

              Working...
              X