Announcement

Collapse
No announcement yet.

Is it possible to get older minor releases of BC4?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is it possible to get older minor releases of BC4?

    For compatibility with older software I have no control over, I am still running Windows XP sevice pack 2. I have Beyond Compare 4.0.0 installed and running, and saw that there was a recent update. However trying to install the latest update I found that XP service pack 3 is required for the latest minor version, 4.0.7. I didn't see any mention of service pack support in the change logs, but I thought that perhaps some version between 4.0.0 and 4.0.7 might still work with XP service pack 2. Are the intermediate minor versions (4.0.1 through 4.0.6) available for download? Any idea when the support for XP service pack 2 was dropped?

  • #2
    Hello,

    We encountered a bug with older versions of Windows which would allow the program to install but then it could not launch or uninstall. Since 4.0.1, we added a flag in the installer to limit it to only tested and supported versions of Windows, and we always require the latest service packs.

    There are two workarounds available for you. We do not host older versions of the setup, but you can email us at support@scootersoftware.com with a link to this forum thread and request one. We can get you a 4.0.0 setup file.

    Alternatively, you can create a Portable Install of 4.0.7 on any supported machine, and use a usb thumb drive, email, etc to bring it over to the XP sp2 machine. A portable install is a single directory install, so you would just run the BCompare.exe from this directory once you copy it to C:\Beyond Compare 4\ or C:\Tools\BC4\ etc. If you need to uninstall a Portable Install, you can just delete it. We haven't tested against SP2 and this is an unsupported method.
    Aaron P Scooter Software

    Comment


    • #3
      Aaron,

      Thank you very much for your reply. I don't need 4.0.0 as I already have it running. I might try the portable installation approach. However it sounds like that would not have the context menu options, which is the usual way I open BC4 (i.e. right click one file/folder select "Select left folder for compare...", etc.).

      Regards,
      Gabor

      Comment


      • #4
        Hello,

        If it helps, there are a couple workarounds for the lack of the context menu. You can click and drag from an Explorer window onto either pane to instantly open that file on that side of BC4. Or drag into any file path to populate the path.

        You could also try to copy/replace the contents of your install directory with the folder of the Portable Install, but do not include the BCState.xml and other BCSetting.xmls when copying into Program Files\. I would back up your current settings (Tools menu -> Export) first, just in case you need to uninstall and reinstall BC4 to revert.
        Aaron P Scooter Software

        Comment

        Working...
        X