Announcement

Collapse
No announcement yet.

Text compare: typing doesn't work any more, but copy/paste by mouse or keyboard does

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Text compare: typing doesn't work any more, but copy/paste by mouse or keyboard does

    I'm having this problem on only one machine. It has two installations of BC4: a portable one and a regular one, both Version 4.0.2 (build 19186).

    The regular one is having problems: I cannot type anything in the text compares any more, but I can copy paste (by keyboard or mouse).
    The portable install functions correctly.

    Before upgrading both, I had the same failure, so suspected a configuration issue.
    So I copied BCState.xml from the regular to the portable install: I get the same issue in the portable install.

    I tried to compare the BCState.xml to the original BCState.xml from the portable install, but they are too different for me to quickly find the cause.

    Anyone who is more familiar with BCState.xml that can help me point at the cause?

  • #2
    I think I found it: the faulty BCState.xml had this

    <?xml version="1.0" encoding="UTF-8"?>
    <!-- Produced by Beyond Compare 4 from Scooter Software -->
    <BCState Version="1" MinVersion="1">
    ...
    <TTextCompareState>
    ...
    <FullEdit Value="False"/>

    How was this value inserted?

    --jeroen

    Comment


    • #3
      Originally posted by jeroenp View Post
      I think I found it: the faulty BCState.xml had this

      <?xml version="1.0" encoding="UTF-8"?>
      <!-- Produced by Beyond Compare 4 from Scooter Software -->
      <BCState Version="1" MinVersion="1">
      ...
      <TTextCompareState>
      ...
      <FullEdit Value="False"/>

      How was this value inserted?
      There is a "Full Edit" mode: http://www.scootersoftware.com/v4hel...ting_text.html
      This is (de)activated by the F2 function key. I must have accidentally deactivated it by going to the Mac OS X menu in VMware Fusion on which the Windows VM runs by pressing Ctrl-F2: http://support.apple.com/en-us/HT201236

      --jeroen

      Comment


      • #4
        Thanks. Full Edit mode is a toggle on the toolbar and F2, and if enabled would prevent typing in the main pane but not in the Text Details section at the bottom. If this happens again, please check the icon in the toolbar to see if it looks like it has been depressed, and you can watch for if any specific actions you are taking are accidentally triggering the button at the same time.
        Aaron P Scooter Software

        Comment

        Working...
        X