Announcement

Collapse
No announcement yet.

No ftp?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No ftp?

    Is it just me or does BC4 not do ftp sessions anymore? Trying it on the Mac version and not finding it. Even tried entering the server address manually but it's a no go.

  • #2
    Hello,

    FTP Profiles are now called "Profiles" (as, we are including various new methods of connecting remotely). On the mac they are under the Beyond Compare menu. Once in this dialog, you can create a New Profile of a type FTP (or SFTP, FTPS, Dropbox, WebDAV, etc). The actual interface is something we're still refining during the beta.

    Entering the server manually should work as long as the syntax is ftp://user@ipaddress/folder/ (same as BC3).

    Are you able to get both of these methods working? Please let us know if you have any trouble.
    Aaron P Scooter Software

    Comment


    • #3
      OK thanks

      Figured it out about half an hour after my post. Just gotta get used to the new interface.

      Comment


      • #4
        If there's anything you're finding especially confusing about it, definitely let us know. The new profile support is quite a change and we're still looking into making it easier to use.
        ZoŽ P Scooter Software

        Comment


        • #5
          I found it confusing, too. I use version 3 on Ubuntu and I was able to connect easily and intuitively. I didn't realize at first that "profile" was what I needed. Then it wasn't clear how to set it up. I have an SSH key, so I can "ssh my_config". It seems like all I should have to put in is "my_config" and it should be able to do the rest. But I even tried the username/password method and the same credentials that worked on Ubuntu didn't work in the new version. (BTW, I'm really excited about the native OSX version! Goodbye Parallels! ... as soon as this works.)

          Comment


          • #6
            Hello,

            At which step in the process did you lose you? BC4's folder paths can accept the same syntax (ftp://user@ip.address/folder) as BC3. The Profile dialog itself and creating a new FTP Profile? Is it that only the "<default>" FTP profile has a location to store a Private Key?
            Aaron P Scooter Software

            Comment


            • #7
              Having the private key only in <default> was confusing. I definitely have more than one key because I have to get on more than one machine.

              But that wasn't the biggest confusion. I think I ran into a bug that I've seen elsewhere that something broke with FTP. I've got version 3 running in Ubuntu under Parallels and could connect just fine, but putting the same URI in on version 4 for OSX didn't. I was able to connect in version 3 using a string that looks something like this:

              sftp://username@server.com/

              On version 4 for the same URI I get "Connection failed (error code is 36)"

              So, if that is a known bug, I'm not actually confused at all.

              Comment


              • #8
                paulie,

                The current BC4 build 17628 introduced a bug that broke SFTP (not plain FTP) on Mac. We're working on a fix, but if you need a workaround before then, email support@scootersoftware.com and we'll provide you a link to the previous beta 4 version that doesn't have this bug.
                Chris K Scooter Software

                Comment

                Working...
                X