No announcement yet.

git difftool regression

  • Filter
  • Time
  • Show
Clear All
new posts

  • git difftool regression

    Hi all,
    I've been using git with Beyond Compare 3 Pro on Windows for some time now. Yesterday I updated my git shell and my Beyond Compare to benefit from the new --dir-diff feature.

    Not only --dir-diff doesn't work (Folder Not Available), but difftool no longer works. It launches text merge instead. Any ideas of how to fix this?

    git: 1.8.0
    BC3: 3.3.5 (build 15075)

    git config
    difftool.prompt false
    difftool.bc4.cmd "c:/program files (x86)/beyond compare 3/bcomp.exe" "$LOCAL" "$REMOTE"
    diff.tool bc3
    difftool.bc3.path c:/program files (x86)/beyond compare 3/bcompare.exe

  • #2

    It looks like you have a couple of extra lines in there. You would usually use either .path or .cmd, and both should use bcomp.exe.

    Also, I notice what looks like a small typo (bc4 instead of bc3). We also do not have the "$variables" in our sample configuration, found here:

    If you back up your current git config file, delete these lines, then run the commands as listed from our KB article, does that get it working for you? Please note the KB article includes instructions for 1.7.6 and newer, or older, versions.
    Aaron P Scooter Software


    • #3
      color.diff auto
      diff.astextplain.textconv astextplain
      diff.tool vs11
      Hello Aaron,
      I've clean it up a bit, here is all I have concerning diff in my .gitconfig.

      difftool.prompt false
      difftool.p4.cmd "c:/program files/Perforce/p4merge.exe" "$LOCAL" "$REMOTE"
      difftool.vs11.cmd "c:/program files (x86)/microsoft visual studio11.0/common7/ide/devenv.exe" '//diff' "$LOCAL" "$REMOTE"
      diff.tool bc3
      difftool.bc3.path c:/program files (x86)/beyond compare 3/bcomp.exe

      Yet, nothing changed. When I difftool a file, 3 way merge is launched. When I run difftool -d, it warns me that "Left" folder doesn't exists.


      • #4
        Just found it. I had an old
        mergetool.bc3.cmd lying around in my system config. I removed it and now it works. Weird that it was conflicting with difftool config... That wasn't a problem before, but with the latest versions it does seem to be an issue.

        Only annoyance left, when I run difftool on many files (branch, dir diff, etc.), it open one after the other many instances of Beyond Compare. I would like one instance of BC3 with many tabs; the same result as when running a diff on a changelist in Perforce... Is this possible?


        • #5
          This may help: We haven't tried it here, but someone on Twitter mentioned it worked well with BC.
          ZoŽ P Scooter Software


          • #6
            I have the same issue than with --dir-diff, is says the left folder doesn't exists.

            So to summarize, git difftool and git difftool <branch> works well but open a new instance of BC for each file, git --dir-diff doesn't work.


            • #7
              --dir-diff is not officially supported, but there are a few other successful reports, here:

              or here:

              Do either of these articles help get you going?
              Aaron P Scooter Software